summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-02-16 04:46:33 +0000
committerSteve Dibb <beandog@gentoo.org>2010-02-16 04:46:33 +0000
commit9c1d12c8808b0ca5d6fe588eaa6a5a6b3bf2d997 (patch)
tree579fc07daab33306d2972e7a56119576bc8de5ad /dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-9c1d12c8808b0ca5d6fe588eaa6a5a6b3bf2d997.tar.gz
gentoo-2-9c1d12c8808b0ca5d6fe588eaa6a5a6b3bf2d997.tar.bz2
gentoo-2-9c1d12c8808b0ca5d6fe588eaa6a5a6b3bf2d997.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild')
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild
new file mode 100644
index 000000000000..95289b4f33b1
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/PEAR-Log-1.12.0.ebuild,v 1.1 2010/02/16 04:46:33 beandog Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system.
+It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal targets."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} sqlite ; then
+ elog "${PN} can optionally use ${PHP_PKG} sqlite features."
+ elog "If you want those, recompile ${PHP_PKG} with this flag in USE."
+ fi
+}