summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-08-16 10:47:02 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-08-16 10:47:02 +0000
commitde4c3aa1edf059df3f6302cdaef3b030aace0811 (patch)
treef85bfd0ae6a4868c70487add022b5712f9c12234 /dev-php/PEAR-PEAR
parentKeyworded ~sparc-fbsd and ~x86-fbsd, #189068 thanks to Jason. (diff)
downloadgentoo-2-de4c3aa1edf059df3f6302cdaef3b030aace0811.tar.gz
gentoo-2-de4c3aa1edf059df3f6302cdaef3b030aace0811.tar.bz2
gentoo-2-de4c3aa1edf059df3f6302cdaef3b030aace0811.zip
Version bump for bug #189075 from php overlay as requested on irc
(Portage version: 2.1.3.5)
Diffstat (limited to 'dev-php/PEAR-PEAR')
-rw-r--r--dev-php/PEAR-PEAR/ChangeLog7
-rw-r--r--dev-php/PEAR-PEAR/PEAR-PEAR-1.6.1.ebuild141
-rw-r--r--dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.115
3 files changed, 162 insertions, 1 deletions
diff --git a/dev-php/PEAR-PEAR/ChangeLog b/dev-php/PEAR-PEAR/ChangeLog
index 53c1031fe357..7bdd0f22a0b7 100644
--- a/dev-php/PEAR-PEAR/ChangeLog
+++ b/dev-php/PEAR-PEAR/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-PEAR
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.86 2007/03/20 19:22:59 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/ChangeLog,v 1.87 2007/08/16 10:47:01 jokey Exp $
+
+*PEAR-PEAR-1.6.1 (16 Aug 2007)
+
+ 16 Aug 2007; Markus Ullmann <jokey@gentoo.org> +PEAR-PEAR-1.6.1.ebuild:
+ Version bump for bug #189075 from php overlay as requested on irc
*PEAR-PEAR-1.5.1 (20 Mar 2007)
diff --git a/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.1.ebuild b/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.1.ebuild
new file mode 100644
index 000000000000..936a2855b623
--- /dev/null
+++ b/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PEAR/PEAR-PEAR-1.6.1.ebuild,v 1.1 2007/08/16 10:47:01 jokey Exp $
+
+inherit depend.php
+
+ARCHIVE_TAR="1.3.2"
+CONSOLE_GETOPT="1.2.3"
+STRUCTURES_GRAPH="1.0.2"
+XML_RPC="1.5.1"
+PEAR="1.6.1"
+
+[[ -z "${PEAR_CACHEDIR}" ]] && PEAR_CACHEDIR="/var/cache/pear"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR Base System (PEAR, Archive_Tar, Console_Getopt, Structures_Graph, XML_RPC)."
+HOMEPAGE="http://pear.php.net/"
+SRC_URI="http://pear.php.net/get/Archive_Tar-${ARCHIVE_TAR}.tgz
+ http://pear.php.net/get/Console_Getopt-${CONSOLE_GETOPT}.tgz
+ http://pear.php.net/get/Structures_Graph-${STRUCTURES_GRAPH}.tgz
+ http://pear.php.net/get/XML_RPC-${XML_RPC}.tgz
+ http://pear.php.net/get/PEAR-${PEAR}.tgz"
+LICENSE="LGPL-2.1 PHP"
+SLOT="0"
+IUSE=""
+
+# we deliberately force people to remove their old PEAR installations,
+# and any package which may have put an old-style PEAR installation onto
+# their box
+# we also depend on a recent sandbox version to mitigate problems users
+# have been experiencing
+
+DEPEND="dev-lang/php
+ !dev-php/php
+ !dev-php/php-cgi
+ !dev-php/mod_php
+ !<dev-php/PEAR-PEAR-1.3.6-r2
+ !dev-php/PEAR-Archive_Tar
+ !dev-php/PEAR-Console_Getopt
+ !dev-php/PEAR-XML_RPC
+ >=sys-apps/sandbox-1.2.17"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # we call this here, to ensure that the eclass picks the right
+ # version of php for the job
+ require_php_cli
+
+ # we check that PHP was compiled with the correct USE flags
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use cli pcre expat zlib
+ else
+ require_php_with_use cli pcre xml zlib
+ fi
+}
+
+src_install() {
+ require_php_cli
+
+ # Prevent SNMP related sandbox violoation.
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/
+
+ mkdir -p "${WORKDIR}/PEAR/XML/RPC"
+
+ # Install PEAR Package.
+ cp -r "${WORKDIR}/PEAR-${PEAR}/OS" "${WORKDIR}/PEAR/"
+ cp -r "${WORKDIR}/PEAR-${PEAR}/PEAR" "${WORKDIR}/PEAR/"
+ cp "${WORKDIR}/PEAR-${PEAR}/PEAR.php" "${WORKDIR}/PEAR/PEAR.php"
+ cp "${WORKDIR}/PEAR-${PEAR}/System.php" "${WORKDIR}/PEAR/System.php"
+
+ # Prepare /usr/bin/pear script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pearcmd.php" "${WORKDIR}/PEAR/pearcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/pearcmd.php" || die "sed failed"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pear.sh" "${WORKDIR}/PEAR/pear"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+ sed -i "s:-d output_buffering=1:-d output_buffering=1 -d memory_limit=32M:g" "${WORKDIR}/PEAR/pear" || die "sed failed"
+
+ # Prepare /usr/bin/peardev script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peardev.sh" "${WORKDIR}/PEAR/peardev"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/peardev" || die "sed failed"
+
+ # Prepare /usr/bin/pecl script.
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/peclcmd.php" "${WORKDIR}/PEAR/peclcmd.php"
+ sed -i "s:@pear_version@:${PEAR}:g" "${WORKDIR}/PEAR/peclcmd.php" || die "sed failed"
+ cp "${WORKDIR}/PEAR-${PEAR}/scripts/pecl.sh" "${WORKDIR}/PEAR/pecl"
+ sed -i "s:@php_bin@:${PHPCLI}:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@bin_dir@:/usr/bin:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+ sed -i "s:@php_dir@:/usr/share/php:g" "${WORKDIR}/PEAR/pecl" || die "sed failed"
+
+ # Prepare PEAR/Dependency2.php.
+ sed -i "s:@PEAR-VER@:${PEAR}:g" "${WORKDIR}/PEAR/PEAR/Dependency2.php" || die "sed failed"
+
+ # Install Archive_Tar Package.
+ cp -r "${WORKDIR}/Archive_Tar-${ARCHIVE_TAR}/Archive" "${WORKDIR}/PEAR/"
+
+ # Install Console_Getopt Package.
+ cp -r "${WORKDIR}/Console_Getopt-${CONSOLE_GETOPT}/Console" "${WORKDIR}/PEAR/"
+
+ # Install Structures_Graph Package.
+ cp -r "${WORKDIR}/Structures_Graph-${STRUCTURES_GRAPH}/Structures" "${WORKDIR}/PEAR/"
+
+ # Install XML_RPC Package.
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/RPC.php" "${WORKDIR}/PEAR/XML/RPC.php"
+ cp "${WORKDIR}/XML_RPC-${XML_RPC}/Server.php" "${WORKDIR}/PEAR/XML/RPC/Server.php"
+
+ # Finalize installation.
+ cd "${WORKDIR}/PEAR"
+ insinto /usr/share/php
+ doins -r Archive Console OS PEAR Structures XML *.php
+ dobin pear peardev pecl
+
+ insinto /etc
+ doins "${FILESDIR}/pear.conf"
+ sed -e "s|s:PHPCLILEN:\"PHPCLI\"|s:${#PHPCLI}:\"${PHPCLI}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
+ sed -e "s|s:CACHEDIRLEN:\"CACHEDIR\"|s:${#PEAR_CACHEDIR}:\"${PEAR_CACHEDIR}\"|g" -i "${D}/etc/pear.conf" || die "sed failed"
+
+ keepdir "${PEAR_CACHEDIR}"
+ fperms 755 "${PEAR_CACHEDIR}"
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}/etc/pear.conf"
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ pearchans="pear.php.net pecl.php.net components.ez.no pear.phpdb.org pear.phing.info pear.symfony-project.com pear.phpunit.de pear.php-baustelle.de"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}
diff --git a/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.1 b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.1
new file mode 100644
index 000000000000..f93e98df92f9
--- /dev/null
+++ b/dev-php/PEAR-PEAR/files/digest-PEAR-PEAR-1.6.1
@@ -0,0 +1,15 @@
+MD5 17d49e837b64df4e8f9124f829b22cd1 Archive_Tar-1.3.2.tgz 17150
+RMD160 cec105d1cdefd502f209c24c217645cec723d7a2 Archive_Tar-1.3.2.tgz 17150
+SHA256 952820c055a770a6d1ecdff487b3de0ff0617a1baca084dac443a6d5f7cde53c Archive_Tar-1.3.2.tgz 17150
+MD5 d7618327f9302a7191893768982de823 Console_Getopt-1.2.3.tgz 4011
+RMD160 d1624dbcb223395ded9e46285f896d6f5bb5ca74 Console_Getopt-1.2.3.tgz 4011
+SHA256 1985b1434c13d5e619643c3712e4144d39f66f6fed61994765e6a0f1623680d8 Console_Getopt-1.2.3.tgz 4011
+MD5 1476f0ec3917d68e3d7af1346a9a7b89 PEAR-1.6.1.tgz 295780
+RMD160 8066006183ec2987e9b9d6fb71e9a5db23b5b550 PEAR-1.6.1.tgz 295780
+SHA256 5534a512970f5169796ab9394fc24a515ca5905782769fd1b715fefd4add2a8b PEAR-1.6.1.tgz 295780
+MD5 2664e2d024048f982e12fad4d1bfbb87 Structures_Graph-1.0.2.tgz 30947
+RMD160 8eb53f6da109b90bab5d8101e99183a1ae116404 Structures_Graph-1.0.2.tgz 30947
+SHA256 d30e72fcb888d17d01d211dd0cdc8bdde8c87554fc4d7de438a4cf0b490a8697 Structures_Graph-1.0.2.tgz 30947
+MD5 1b516162ad65971b5fd04a7c279627ec XML_RPC-1.5.1.tgz 32215
+RMD160 6e8b9f4698285609d9c9d4450c59c16083607ee8 XML_RPC-1.5.1.tgz 32215
+SHA256 a5b517eef799df148d6c85ab19e188715a22c069f4507dcb792e5efb7d0f117e XML_RPC-1.5.1.tgz 32215