summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-09-11 20:05:57 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-09-11 20:05:57 +0000
commit339754779181bf12231a6f1c0a76540f6bce1930 (patch)
tree42dc232616bb720ad4cee62d13cf060c0f60945c /dev-php/libvirt-php
parentbump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838 (diff)
downloadgentoo-2-339754779181bf12231a6f1c0a76540f6bce1930.tar.gz
gentoo-2-339754779181bf12231a6f1c0a76540f6bce1930.tar.bz2
gentoo-2-339754779181bf12231a6f1c0a76540f6bce1930.zip
Version bump
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/ChangeLog7
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.4.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-php/libvirt-php/ChangeLog b/dev-php/libvirt-php/ChangeLog
index fcc5fea65197..d6dc5627d7ff 100644
--- a/dev-php/libvirt-php/ChangeLog
+++ b/dev-php/libvirt-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/libvirt-php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.3 2012/07/19 06:25:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.4 2012/09/11 20:05:57 cardoe Exp $
+
+*libvirt-php-0.4.6 (11 Sep 2012)
+
+ 11 Sep 2012; Doug Goldstein <cardoe@gentoo.org> +libvirt-php-0.4.6.ebuild:
+ Version bump
19 Jul 2012; Tiziano Müller <dev-zero@gentoo.org> libvirt-php-9999.ebuild:
Update live ebuild for proper multi-slot building.
diff --git a/dev-php/libvirt-php/libvirt-php-0.4.6.ebuild b/dev-php/libvirt-php/libvirt-php-0.4.6.ebuild
new file mode 100644
index 000000000000..e44c838c3cb4
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.4.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/libvirt-php-0.4.6.ebuild,v 1.1 2012/09/11 20:05:57 cardoe Exp $
+
+EAPI=4
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-source-r2 eutils
+
+DESCRIPTION="PHP 5 bindings for libvirt."
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${DEPEND}
+ doc? ( app-text/xhtml1 dev-libs/libxslt )"
+
+RESTRICT="test"
+
+src_unpack() {
+ default
+ # create the default modules directory to be able
+ # to use the php-ext-source-r2 eclass to configure/build
+ ln -s src "${S}/modules"
+
+ for slot in $(php_get_slots); do
+ cp -r "${S}" "${WORKDIR}/${slot}"
+ done
+}
+
+src_install() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml docs/* docs/graphics/*
+}