summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-03-02 05:12:07 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-03-02 05:12:07 +0000
commit47b24e1c77206f3adf55e4a612b64bcf791fed96 (patch)
treed122075368b7fd61bddb46256e0f5c5e09b6a815 /dev-php/libvirt-php
parentVersion bump. (diff)
downloadgentoo-2-47b24e1c77206f3adf55e4a612b64bcf791fed96.tar.gz
gentoo-2-47b24e1c77206f3adf55e4a612b64bcf791fed96.tar.bz2
gentoo-2-47b24e1c77206f3adf55e4a612b64bcf791fed96.zip
Version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/ChangeLog9
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.4.7.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-php/libvirt-php/ChangeLog b/dev-php/libvirt-php/ChangeLog
index 282ee78ad5bc..b7141be2dec4 100644
--- a/dev-php/libvirt-php/ChangeLog
+++ b/dev-php/libvirt-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/libvirt-php
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.5 2012/11/05 06:13:37 dev-zero Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.6 2013/03/02 05:12:07 cardoe Exp $
+
+*libvirt-php-0.4.7 (02 Mar 2013)
+
+ 02 Mar 2013; Doug Goldstein <cardoe@gentoo.org> +libvirt-php-0.4.7.ebuild:
+ Version bump
05 Nov 2012; Tiziano Müller <dev-zero@gentoo.org> libvirt-php-0.4.2.ebuild,
libvirt-php-0.4.6.ebuild, libvirt-php-9999.ebuild:
diff --git a/dev-php/libvirt-php/libvirt-php-0.4.7.ebuild b/dev-php/libvirt-php/libvirt-php-0.4.7.ebuild
new file mode 100644
index 000000000000..d1664798507d
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.4.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/libvirt-php-0.4.7.ebuild,v 1.1 2013/03/02 05:12:07 cardoe Exp $
+
+EAPI=4
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-source-r2 eutils
+
+DESCRIPTION="PHP 5 bindings for libvirt."
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ doc? ( app-text/xhtml1 )"
+
+RESTRICT="test"
+
+src_unpack() {
+ default
+ # create the default modules directory to be able
+ # to use the php-ext-source-r2 eclass to configure/build
+ ln -s src "${S}/modules"
+
+ for slot in $(php_get_slots); do
+ cp -r "${S}" "${WORKDIR}/${slot}"
+ done
+}
+
+src_install() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml docs/* docs/graphics/*
+}