summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-13 16:49:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-13 16:49:51 +0000
commit25ab1257ee6907f87ade4039a87093b96c806e05 (patch)
treef78c9255f6df9df2b00177034ca82c8ac0116b37 /dev-php/mod_php
parentadded installation of header files. (diff)
downloadgentoo-2-25ab1257ee6907f87ade4039a87093b96c806e05.tar.gz
gentoo-2-25ab1257ee6907f87ade4039a87093b96c806e05.tar.bz2
gentoo-2-25ab1257ee6907f87ade4039a87093b96c806e05.zip
Added Quequero's tweaks... Install headers... Fixes #13721
Diffstat (limited to 'dev-php/mod_php')
-rw-r--r--dev-php/mod_php/ChangeLog9
-rw-r--r--dev-php/mod_php/mod_php-4.3.0-r2.ebuild23
2 files changed, 25 insertions, 7 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index b15e54b66700..e98d2582acb4 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.43 2003/01/13 08:54:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.44 2003/01/13 16:49:51 rphillips Exp $
+
+*mod_php-4.3.0-r2 (10 Jan 2003)
+
+ 13 Jan 2003; Ryan Phillips <rphillips@gentoo.org> mod_php-4.3.0-r2.ebuild :
+ Added Quequero tweaks. Fixes #13721
13 Jan 2003; Daniel Ahlberg <aliz@genoto.org> mod_php-4.3.0-r2.ebuild :
Added ppc and alpha keyword becuse this is a security update.
-*mod_php-4.3.0-r2 (10 Jan 2003)
-
10 Jan 2003; Ryan Phillips <rphillips@gentoo.org> mod_php-4.3.0-r2.ebuild :
Added third party helper scripts to the install. (phpize, php-config, and phpextdist)
Fixes #13525
diff --git a/dev-php/mod_php/mod_php-4.3.0-r2.ebuild b/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
index db25c5ff6ebe..0a970f869cac 100644
--- a/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.0-r2.ebuild,v 1.2 2003/01/13 08:54:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.0-r2.ebuild,v 1.3 2003/01/13 16:49:51 rphillips Exp $
-IUSE="apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
+IUSE="png apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -25,6 +25,7 @@ DEPEND="
jpeg? ( >=media-libs/jpeg-6b )
tiff? ( >=media-libs/tiff-3.5.5 )
X? ( virtual/x11 )
+ png? ( >=media-libs/libpng-1.2.5 )
qt? ( x11-libs/qt )
nls? ( sys-devel/gettext )
pam? ( >=sys-libs/pam-0.75 )
@@ -120,6 +121,16 @@ src_compile() {
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+ if [ "`use png`" ] ; then
+ myconf="${myconf} --with-png-dir=/usr/lib"
+ fi
+
+ # And zlib, but we need to know if the user wants it - Quequero
+ if [ "`use zlib`" ] ; then
+ myconf="${myconf} --with-zlib"
+ myconf="${myconf} --with-zlib-dir=/usr/lib"
+ fi
+
# optional support for apache2
myconf="${myconf} --with-exec-dir=/usr/bin"
if [ "`use apache2`" ] ; then
@@ -128,6 +139,7 @@ src_compile() {
myconf="${myconf} --with-apxs=/usr/sbin/apxs"
fi
+
# optional support for oracle oci8
if [ "`use oci8`" ] ; then
if [ "$ORACLE_HOME" ] ; then
@@ -173,13 +185,16 @@ src_compile() {
fi
# this needed moving to prevent b0rkage
- # Please test your ebuilds!
# --with-gmp \
./configure \
--prefix=/usr \
--with-bz2 \
--enable-ftp \
+ --enable-force-cgi-redirect \
+ --enable-discard-path \
+ --enable-gd-native-ttf \
+ --enable-mime-magic \
--enable-wddx \
--enable-dbase \
--with-zlib=yes \
@@ -205,7 +220,7 @@ src_compile() {
src_install() {
addwrite /usr/share/snmp/mibs/.index
- make INSTALL_ROOT=${D} install-pear || die
+ make INSTALL_ROOT=${D} install-pear install-headers || die
dodoc CODING_STANDARDS LICENSE EXTENSIONS
dodoc README.* TODO NEWS