summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-07-29 08:28:15 +0000
committerMatti Bickel <mabi@gentoo.org>2010-07-29 08:28:15 +0000
commit06515c138df566e0ba03ad809cdde2d182eb9a23 (patch)
treece6bc8b8867c2245cac38f28a4eed9ca7257401d /dev-php5/pecl-apc
parentamd64 stable, bug #330123 (diff)
downloadgentoo-2-06515c138df566e0ba03ad809cdde2d182eb9a23.tar.gz
gentoo-2-06515c138df566e0ba03ad809cdde2d182eb9a23.tar.bz2
gentoo-2-06515c138df566e0ba03ad809cdde2d182eb9a23.zip
bug #330093
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-apc')
-rw-r--r--dev-php5/pecl-apc/ChangeLog10
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.1.3_p1-r1.ebuild72
2 files changed, 80 insertions, 2 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index ae2f7748be47..68925344b427 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-apc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.54 2009/12/02 19:02:54 hanno Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.55 2010/07/29 08:28:15 mabi Exp $
+
+*pecl-apc-3.1.3_p1-r1 (29 Jul 2010)
+
+ 29 Jul 2010; Matti Bickel <mabi@gentoo.org> +pecl-apc-3.1.3_p1-r1.ebuild:
+ remove no longer recognized apache config option, support building with
+ fpm (bug #330093)
*pecl-apc-3.1.3_p1 (02 Dec 2009)
diff --git a/dev-php5/pecl-apc/pecl-apc-3.1.3_p1-r1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.1.3_p1-r1.ebuild
new file mode 100644
index 000000000000..4f2e1bf68325
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.1.3_p1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.3_p1-r1.ebuild,v 1.1 2010/07/29 08:28:15 mabi Exp $
+
+EAPI=2
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+inherit php-ext-pecl-r1 confutils eutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache
+ || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.filters" '""'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.report_autofilter" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_prefix" '"upload_"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_name" '"APC_UPLOAD_PROGRESS"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_freq" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache.size" '"512"'
+ php-ext-base-r1_addtoinifiles "apc.coredump_unmap" '"0"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}