summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-09-13 13:54:55 +0000
committerMatti Bickel <mabi@gentoo.org>2010-09-13 13:54:55 +0000
commit0c2d2d212412ffe96081f454e283b03f4da909f7 (patch)
tree490d722c10e9ddda706ab09452d200fa7c77a509 /dev-php5
parentadd default src_test for pecl packages (diff)
downloadgentoo-2-0c2d2d212412ffe96081f454e283b03f4da909f7.tar.gz
gentoo-2-0c2d2d212412ffe96081f454e283b03f4da909f7.tar.bz2
gentoo-2-0c2d2d212412ffe96081f454e283b03f4da909f7.zip
cleanup, version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-apc/ChangeLog10
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.16-r1.ebuild79
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild66
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild76
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.18.ebuild66
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.1.4.ebuild (renamed from dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild)16
6 files changed, 15 insertions, 298 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index 68925344b427..96942982e3c5 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.55 2010/07/29 08:28:15 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.56 2010/09/13 13:54:55 mabi Exp $
+
+*pecl-apc-3.1.4 (13 Sep 2010)
+
+ 13 Sep 2010; Matti Bickel <mabi@gentoo.org> -pecl-apc-3.0.16-r1.ebuild,
+ -pecl-apc-3.0.17.ebuild, -pecl-apc-3.0.18.ebuild,
+ -pecl-apc-3.0.18-r1.ebuild, -pecl-apc-3.1.3_p1.ebuild,
+ +pecl-apc-3.1.4.ebuild:
+ cleanup, version bump
*pecl-apc-3.1.3_p1-r1 (29 Jul 2010)
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.16-r1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.16-r1.ebuild
deleted file mode 100644
index c2032379be0f..000000000000
--- a/dev-php5/pecl-apc/pecl-apc-3.0.16-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.16-r1.ebuild,v 1.7 2009/11/03 17:33:08 armin76 Exp $
-
-PHP_EXT_NAME="apc"
-PHP_EXT_PECL_PKG="APC"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
-
-inherit php-ext-pecl-r1 confutils eutils
-
-KEYWORDS="amd64 ~ia64 ppc ~ppc64 sparc x86"
-
-DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="mmap"
-
-DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- has_php
- require_php_sapi_from cgi apache2
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # patch for CVE-2008-1488, Bug 214576
- epatch "${FILESDIR}"/${P}-CVE-2008-1488.patch
- # http://pecl.php.net/bugs/bug.php?id=12777, Bug 204224
- epatch "${FILESDIR}"/${P}-apc_set_signals.patch
-
- php-ext-source-r1_phpize
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-apc"
- enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
- php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
- php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
- php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
- php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
- php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
- php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
- php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
- php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
- php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
- php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
-
- dodir "${PHP_EXT_SHARED_DIR}"
- insinto "${PHP_EXT_SHARED_DIR}"
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of PECL-APC was"
- elog "installed into ${ROOT}usr/share/php5/apc/."
-}
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild
deleted file mode 100644
index 9e3498549f10..000000000000
--- a/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild,v 1.4 2009/11/03 17:33:08 armin76 Exp $
-
-PHP_EXT_NAME="apc"
-PHP_EXT_PECL_PKG="APC"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
-
-inherit php-ext-pecl-r1 confutils eutils
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="mmap"
-
-DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- require_php_sapi_from cgi apache2
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-apc"
- enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
- php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
- php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
- php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
- php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
- php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
- php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
- php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
- php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
- php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
- php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
-
- dodir "${PHP_EXT_SHARED_DIR}"
- insinto "${PHP_EXT_SHARED_DIR}"
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of PECL-APC was"
- elog "installed into ${ROOT}usr/share/php5/apc/."
-}
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild
deleted file mode 100644
index e0be35f950c8..000000000000
--- a/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.18-r1.ebuild,v 1.2 2009/11/03 17:33:08 armin76 Exp $
-
-PHP_EXT_NAME="apc"
-PHP_EXT_PECL_PKG="APC"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
-
-inherit php-ext-pecl-r1 confutils eutils
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="mmap"
-
-DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- require_php_sapi_from cgi apache2
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-apc"
- enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
- php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
- php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
- php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
- php-ext-base-r1_addtoinifiles ";apc.filters" '""'
- php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
- php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
- php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
- php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
- php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
- php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
- php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
- php-ext-base-r1_addtoinifiles "apc.report_autofilter" '"0"'
- php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
- php-ext-base-r1_addtoinifiles "apc.rfc1867" '"0"'
- php-ext-base-r1_addtoinifiles "apc.rfc1867_prefix" '"upload_"'
- php-ext-base-r1_addtoinifiles "apc.rfc1867_name" '"APC_UPLOAD_PROGRESS"'
- php-ext-base-r1_addtoinifiles "apc.rfc1867_freq" '"0"'
- php-ext-base-r1_addtoinifiles "apc.localcache" '"0"'
- php-ext-base-r1_addtoinifiles "apc.localcache.size" '"512"'
- php-ext-base-r1_addtoinifiles "apc.coredump_unmap" '"0"'
-
- dodir "${PHP_EXT_SHARED_DIR}"
- insinto "${PHP_EXT_SHARED_DIR}"
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of PECL-APC was"
- elog "installed into ${ROOT}usr/share/php5/apc/."
-}
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.18.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.18.ebuild
deleted file mode 100644
index 3f03ccec89e0..000000000000
--- a/dev-php5/pecl-apc/pecl-apc-3.0.18.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.18.ebuild,v 1.2 2009/11/03 17:33:08 armin76 Exp $
-
-PHP_EXT_NAME="apc"
-PHP_EXT_PECL_PKG="APC"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
-
-inherit php-ext-pecl-r1 confutils eutils
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="mmap"
-
-DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
-RDEPEND="${DEPEND}"
-
-need_php_by_category
-
-pkg_setup() {
- require_php_sapi_from cgi apache2
-}
-
-src_compile() {
- has_php
-
- my_conf="--enable-apc"
- enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
-
- php-ext-pecl-r1_src_compile
-}
-
-src_install() {
- php-ext-pecl-r1_src_install
-
- php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
- php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
- php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
- php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
- php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
- php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
- php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
- php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
- php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
- php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
- php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
- php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
- php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
-
- dodir "${PHP_EXT_SHARED_DIR}"
- insinto "${PHP_EXT_SHARED_DIR}"
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of PECL-APC was"
- elog "installed into ${ROOT}usr/share/php5/apc/."
-}
diff --git a/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.1.4.ebuild
index c9420a596764..3b8239249f75 100644
--- a/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild
+++ b/dev-php5/pecl-apc/pecl-apc-3.1.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild,v 1.1 2009/12/02 19:02:54 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.4.ebuild,v 1.1 2010/09/13 13:54:55 mabi Exp $
+
+EAPI=2
PHP_EXT_NAME="apc"
PHP_EXT_PECL_PKG="APC"
@@ -17,21 +19,15 @@ LICENSE="PHP-3.01"
SLOT="0"
IUSE="mmap"
-DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache
+ || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )"
RDEPEND="${DEPEND}"
need_php_by_category
-pkg_setup() {
- require_php_sapi_from cgi apache2
-}
-
src_compile() {
- has_php
-
my_conf="--enable-apc"
enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
php-ext-pecl-r1_src_compile
}