summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-06-17 13:19:08 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-06-17 13:19:08 +0000
commit89a0f4bd3e0bdec06d8689c7289e7174340e332c (patch)
tree8b382efb17c6bf08adf13b4f56a594031638ef80 /dev-php5
parentFix building for alpha #227275. (diff)
downloadgentoo-2-89a0f4bd3e0bdec06d8689c7289e7174340e332c.tar.gz
gentoo-2-89a0f4bd3e0bdec06d8689c7289e7174340e332c.tar.bz2
gentoo-2-89a0f4bd3e0bdec06d8689c7289e7174340e332c.zip
* bump
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/onphp/ChangeLog9
-rw-r--r--dev-php5/onphp/onphp-0.10.11.ebuild33
-rw-r--r--dev-php5/onphp/onphp-1.0.5.ebuild33
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-php5/onphp/ChangeLog b/dev-php5/onphp/ChangeLog
index c0ec1f606773..3650e067aab9 100644
--- a/dev-php5/onphp/ChangeLog
+++ b/dev-php5/onphp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/onphp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.58 2008/03/30 19:50:57 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.59 2008/06/17 13:19:08 voxus Exp $
+
+*onphp-1.0.5 (17 Jun 2008)
+*onphp-0.10.11 (17 Jun 2008)
+
+ 17 Jun 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +onphp-0.10.11.ebuild, +onphp-1.0.5.ebuild:
+ Version bump.
*onphp-1.0.4 (30 Mar 2008)
diff --git a/dev-php5/onphp/onphp-0.10.11.ebuild b/dev-php5/onphp/onphp-0.10.11.ebuild
new file mode 100644
index 000000000000..a0f72e6b7b91
--- /dev/null
+++ b/dev-php5/onphp/onphp-0.10.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.10.11.ebuild,v 1.1 2008/06/17 13:19:08 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}
diff --git a/dev-php5/onphp/onphp-1.0.5.ebuild b/dev-php5/onphp/onphp-1.0.5.ebuild
new file mode 100644
index 000000000000..4b2a5ee69591
--- /dev/null
+++ b/dev-php5/onphp/onphp-1.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-1.0.5.ebuild,v 1.1 2008/06/17 13:19:08 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}