summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-12-02 19:02:54 +0000
committerHanno Böck <hanno@gentoo.org>2009-12-02 19:02:54 +0000
commit8bf626eea82f65571bc51bea1b072c8828c81374 (patch)
treed325573a1445f72d157782998cf261a27a1397f3 /dev-php5
parentCorrect patch reason. (diff)
downloadgentoo-2-8bf626eea82f65571bc51bea1b072c8828c81374.tar.gz
gentoo-2-8bf626eea82f65571bc51bea1b072c8828c81374.tar.bz2
gentoo-2-8bf626eea82f65571bc51bea1b072c8828c81374.zip
pecl-apc bump
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-apc/ChangeLog7
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index caeeff411f8c..ae2f7748be47 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.53 2009/11/03 17:33:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.54 2009/12/02 19:02:54 hanno Exp $
+
+*pecl-apc-3.1.3_p1 (02 Dec 2009)
+
+ 02 Dec 2009; Hanno Boeck <hanno@gentoo.org> +pecl-apc-3.1.3_p1.ebuild:
+ Version bump, supports PHP 5.3.
03 Nov 2009; Raúl Porcel <armin76@gentoo.org> pecl-apc-3.0.16-r1.ebuild,
pecl-apc-3.0.17.ebuild, pecl-apc-3.0.18.ebuild, pecl-apc-3.0.18-r1.ebuild,
diff --git a/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild b/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild
new file mode 100644
index 000000000000..c9420a596764
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.1.3_p1.ebuild,v 1.1 2009/12/02 19:02:54 hanno Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+inherit php-ext-pecl-r1 confutils eutils
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.filters" '""'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.report_autofilter" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.include_once_override" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_prefix" '"upload_"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_name" '"APC_UPLOAD_PROGRESS"'
+ php-ext-base-r1_addtoinifiles "apc.rfc1867_freq" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.localcache.size" '"512"'
+ php-ext-base-r1_addtoinifiles "apc.coredump_unmap" '"0"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}