summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-06-30 10:18:23 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-06-30 10:18:23 +0000
commit7006078bae4e5773f43d3710afd1c108a1859392 (patch)
tree3cf0463a810ecd06ff3921875f5b69a841baec04 /dev-php
parentmark stable on x86 (diff)
downloadgentoo-2-7006078bae4e5773f43d3710afd1c108a1859392.tar.gz
gentoo-2-7006078bae4e5773f43d3710afd1c108a1859392.tar.bz2
gentoo-2-7006078bae4e5773f43d3710afd1c108a1859392.zip
messed up the apache2 config fix
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/mod_php-4.3.2-r3.ebuild13
-rw-r--r--dev-php/mod_php/mod_php-4.3.2.ebuild11
3 files changed, 20 insertions, 8 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index e7edb33b0e01..661fd524e88e 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,8 +1,8 @@
-MD5 75b2655fca588a345ddd693cf40b3218 mod_php-4.3.2.ebuild 3178
+MD5 c80ff5ca38fe3f99cb337639ee92ab7c mod_php-4.3.2.ebuild 3361
MD5 f389bde39dbbb564cafe6d6373ca7a9e mod_php-4.3.2-r2.ebuild 3667
MD5 a2abdac0d990f87991007345db84281b mod_php-4.3.2-r1.ebuild 2730
MD5 76731f74c469016057c2fe2e821bfdb4 ChangeLog 19162
-MD5 eeaf122d117dcf9edb21b4e1270f4b5b mod_php-4.3.2-r3.ebuild 4723
+MD5 db508b84fd50ba7e2281c56421c893f6 mod_php-4.3.2-r3.ebuild 4908
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 b8b9eaba318ccf5b095a857847f00465 files/70_mod_php.conf 1066
MD5 9eb059611498a51db4d0d4b993ceb7a2 files/digest-mod_php-4.3.2 63
diff --git a/dev-php/mod_php/mod_php-4.3.2-r3.ebuild b/dev-php/mod_php/mod_php-4.3.2-r3.ebuild
index 26be1eebf79b..c6844bc90248 100644
--- a/dev-php/mod_php/mod_php-4.3.2-r3.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r3.ebuild,v 1.1 2003/06/30 10:05:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2-r3.ebuild,v 1.2 2003/06/30 10:18:21 robbat2 Exp $
IUSE="${IUSE} apache2"
@@ -125,11 +125,18 @@ multiinstwarn() {
ewarn "copies."
}
+apache2fix() {
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ local oldfile="/etc/conf.d/apache2.old.`date +%Y%m%d%H%M%S`"
+ cp /etc/conf.d/apache2 ${oldfile}
+ sed -e 's,-D PHP,-D PHP4,g' ${oldfile} <${oldfile} >/etc/conf.d/apache2
+}
+
+
pkg_preinst() {
multiinstwarn
+ [ "${APACHEVER}" -eq '2' ] && apache2fix
php_pkg_preinst
- einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
- dosed 's,-D PHP,-D PHP4,' /etc/conf.d/apache2
}
pkg_postinst() {
diff --git a/dev-php/mod_php/mod_php-4.3.2.ebuild b/dev-php/mod_php/mod_php-4.3.2.ebuild
index 9a2b9da0f217..88488b475bf3 100644
--- a/dev-php/mod_php/mod_php-4.3.2.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2.ebuild,v 1.5 2003/06/30 10:05:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2.ebuild,v 1.6 2003/06/30 10:18:21 robbat2 Exp $
use apache2 && PHPSAPI="apache2" || PHPSAPI="apache1"
inherit php eutils
@@ -81,11 +81,16 @@ apache2msg() {
ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
ewarn "to make this update between PHP and PHP4 automatically"
}
+apache2fix() {
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ local oldfile="/etc/conf.d/apache2.old.`date +%Y%m%d%H%M%S`"
+ cp /etc/conf.d/apache2 ${oldfile}
+ sed -e 's,-D PHP,-D PHP4,g' ${oldfile} <${oldfile} >/etc/conf.d/apache2
+}
pkg_preinst() {
+ [ "${APACHEVER}" -eq '2' ] && apache2fix
php_pkg_preinst
- einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
- dosed 's,-D PHP,-D PHP4,' /etc/conf.d/apache2
}
pkg_postinst() {