summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2005-05-12 13:41:42 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2005-05-12 13:41:42 +0000
commitbf5f19a655ef00cd068b35bc603d2f7631f9cd02 (patch)
tree0822cbe2011c7eb8b12358855a60e411db56baf1 /dev-php
parentadd ~ia64 (diff)
downloadgentoo-2-bf5f19a655ef00cd068b35bc603d2f7631f9cd02.tar.gz
gentoo-2-bf5f19a655ef00cd068b35bc603d2f7631f9cd02.tar.bz2
gentoo-2-bf5f19a655ef00cd068b35bc603d2f7631f9cd02.zip
Add force-cgi-redirect USE flag.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php-cgi/ChangeLog6
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild10
-rw-r--r--dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild10
3 files changed, 19 insertions, 7 deletions
diff --git a/dev-php/php-cgi/ChangeLog b/dev-php/php-cgi/ChangeLog
index c43f3f79e3c0..3d24d9baece8 100644
--- a/dev-php/php-cgi/ChangeLog
+++ b/dev-php/php-cgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php-cgi
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.67 2005/05/11 05:33:34 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/ChangeLog,v 1.68 2005/05/12 13:41:42 sebastian Exp $
+
+ 12 May 2005; Sebastian Bergmann <sebastian@gentoo.org>
+ php-cgi-4.3.11-r1.ebuild, php-cgi-5.0.3-r1.ebuild:
+ Add force-cgi-redirect USE flag.
*php-cgi-5.0.3-r1 (11 May 2005)
diff --git a/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild b/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
index 323a950b1469..96b5c461ea4f 100644
--- a/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
+++ b/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild,v 1.1 2005/05/11 05:29:30 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild,v 1.2 2005/05/12 13:41:42 sebastian Exp $
PHPSAPI="cgi"
inherit php-sapi eutils
DESCRIPTION="PHP CGI"
SLOT="0"
+IUSE="${IUSE} force-cgi-redirect"
KEYWORDS="x86 sparc alpha hppa ppc ia64 amd64 ~mips"
# for this revision only
@@ -28,8 +29,11 @@ src_compile() {
myconf="${myconf} \
--enable-cgi \
--enable-cli \
- --enable-fastcgi \
- --enable-force-cgi-redirect"
+ --enable-fastcgi"
+
+ if use force-cgi-redirect; then
+ my_conf="${my_conf} --enable-force-cgi-redirect"
+ fi
php-sapi_src_compile
}
diff --git a/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild b/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild
index 6e6028e3211b..e6cc21a0c798 100644
--- a/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild
+++ b/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild,v 1.1 2005/05/11 05:33:34 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-5.0.3-r1.ebuild,v 1.2 2005/05/12 13:41:42 sebastian Exp $
PHPSAPI="cgi"
MY_P="php-${PV}"
@@ -9,6 +9,7 @@ inherit php5-sapi eutils
DESCRIPTION="PHP CGI"
SLOT="0"
+IUSE="${IUSE} force-cgi-redirect"
KEYWORDS="~ia64 ~ppc ~x86 ~ppc64 ~sparc ~amd64"
# provides all base PHP extras (eg PEAR, extension building stuff)
@@ -29,8 +30,11 @@ src_compile() {
my_conf="${my_conf} \
--enable-cgi \
--enable-cli \
- --enable-fastcgi \
- --enable-force-cgi-redirect"
+ --enable-fastcgi"
+
+ if use force-cgi-redirect; then
+ my_conf="${my_conf} --enable-force-cgi-redirect"
+ fi
php5-sapi_src_compile
}