summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-07 19:27:49 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-07 19:27:49 +0000
commit2e9f5b63fa4a111a57ea01ac029748d39ce93589 (patch)
tree6c44c65f499190bae3be85f11fc1f51cc2312956 /dev-python/ScientificPython
parentan interface for array oriented data access (diff)
downloadgentoo-2-2e9f5b63fa4a111a57ea01ac029748d39ce93589.tar.gz
gentoo-2-2e9f5b63fa4a111a57ea01ac029748d39ce93589.tar.bz2
gentoo-2-2e9f5b63fa4a111a57ea01ac029748d39ce93589.zip
a new python module from tod
Diffstat (limited to 'dev-python/ScientificPython')
-rw-r--r--dev-python/ScientificPython/ScientificPython-2.2.ebuild25
-rw-r--r--dev-python/ScientificPython/files/digest-ScientificPython-2.21
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ScientificPython/ScientificPython-2.2.ebuild b/dev-python/ScientificPython/ScientificPython-2.2.ebuild
new file mode 100644
index 000000000000..a14db8a23dba
--- /dev/null
+++ b/dev-python/ScientificPython/ScientificPython-2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod M. Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/dev-python/scientific--python/ScientificPython-2.2.ebuild,v 1.4 2001/06/04 21:57:52 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="scientific python module"
+SRC_URI="http://starship.python.net/crew/hinsen/"${A}
+HOMEPAGE="http://starship.python.net/crew/hinsen/scientific.html"
+
+DEPEND=">=dev-lang/python-2.0-r4
+ >=dev-python/Numeric-19.0
+ >=app-misc/netcdf-3.0"
+
+src_compile() {
+ try python setup.py build
+}
+
+src_install() {
+ try python setup.py install --prefix=${D}/usr
+ dodoc MANIFEST.in
+ dodoc COPYRIGHT
+ dodoc README*
+}
diff --git a/dev-python/ScientificPython/files/digest-ScientificPython-2.2 b/dev-python/ScientificPython/files/digest-ScientificPython-2.2
new file mode 100644
index 000000000000..b6049f4fdc9c
--- /dev/null
+++ b/dev-python/ScientificPython/files/digest-ScientificPython-2.2
@@ -0,0 +1 @@
+MD5 c5c5ecfe6d6973d5c8d465ccf192b266 ScientificPython-2.2.tar.gz