summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-05 07:58:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-05 07:58:55 +0000
commita2c998ba7eab1d938172b3f2c481959791a25822 (patch)
tree8f6019eb05a88a93364200caf2bcc09277e3ab80 /dev-python/alembic
parentremove texlive 2011 (diff)
downloadgentoo-2-a2c998ba7eab1d938172b3f2c481959791a25822.tar.gz
gentoo-2-a2c998ba7eab1d938172b3f2c481959791a25822.tar.bz2
gentoo-2-a2c998ba7eab1d938172b3f2c481959791a25822.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/ChangeLog7
-rw-r--r--dev-python/alembic/alembic-0.6.7.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/alembic/ChangeLog b/dev-python/alembic/ChangeLog
index f8fe6079f3a6..326bf740465f 100644
--- a/dev-python/alembic/ChangeLog
+++ b/dev-python/alembic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/alembic
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.13 2014/07/06 12:36:26 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/ChangeLog,v 1.14 2014/11/05 07:58:55 patrick Exp $
+
+*alembic-0.6.7 (05 Nov 2014)
+
+ 05 Nov 2014; Patrick Lauer <patrick@gentoo.org> +alembic-0.6.7.ebuild:
+ Bump
06 Jul 2014; Michał Górny <mgorny@gentoo.org> alembic-0.6.0.ebuild,
alembic-0.6.3.ebuild, alembic-0.6.4.ebuild:
diff --git a/dev-python/alembic/alembic-0.6.7.ebuild b/dev-python/alembic/alembic-0.6.7.ebuild
new file mode 100644
index 000000000000..0d436ebea81b
--- /dev/null
+++ b/dev-python/alembic/alembic-0.6.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/alembic/alembic-0.6.7.ebuild,v 1.1 2014/11/05 07:58:55 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ sed -e 's:class SourcelessVersioningTest(VersioningTest):#&:' \
+ -e 's:sourceless = True:#&:' \
+ -e 's:test_needs_flag:_&:' \
+ -i tests/test_versioning.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}