summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-16 09:39:15 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-16 09:39:15 +0000
commitb46a10bd6f55b72a3c6b6840820a92a386b4b96d (patch)
treee48a11248dbd666134ce1e765a081dcde9dc43f6 /dev-python/amara
parentStable latest on amd64 and x86. Punt older. (diff)
downloadgentoo-2-b46a10bd6f55b72a3c6b6840820a92a386b4b96d.tar.gz
gentoo-2-b46a10bd6f55b72a3c6b6840820a92a386b4b96d.tar.bz2
gentoo-2-b46a10bd6f55b72a3c6b6840820a92a386b4b96d.zip
Version bump (bug #393587, dropped old depending on 4suite for bug #250930).
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/amara')
-rw-r--r--dev-python/amara/ChangeLog12
-rw-r--r--dev-python/amara/amara-1.2.0.2.ebuild51
-rw-r--r--dev-python/amara/amara-2.0.0_alpha6.ebuild45
-rw-r--r--dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch45
-rw-r--r--dev-python/amara/files/2.0.0_alpha6-unbundle-python-libs.patch32
5 files changed, 132 insertions, 53 deletions
diff --git a/dev-python/amara/ChangeLog b/dev-python/amara/ChangeLog
index 3c5dae92ab0c..e76498067d12 100644
--- a/dev-python/amara/ChangeLog
+++ b/dev-python/amara/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/amara
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/ChangeLog,v 1.2 2010/07/22 14:39:48 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/ChangeLog,v 1.3 2012/05/16 09:39:14 dev-zero Exp $
+
+*amara-2.0.0_alpha6 (16 May 2012)
+
+ 16 May 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +files/2.0.0_alpha6-unbundle-expat.patch,
+ +files/2.0.0_alpha6-unbundle-python-libs.patch, -amara-1.2.0.2.ebuild,
+ +amara-2.0.0_alpha6.ebuild:
+ Version bump (bug #393587, dropped old depending on 4suite for bug #250930).
22 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
amara-1.2.0.2.ebuild:
diff --git a/dev-python/amara/amara-1.2.0.2.ebuild b/dev-python/amara/amara-1.2.0.2.ebuild
deleted file mode 100644
index f24c7de84d7d..000000000000
--- a/dev-python/amara/amara-1.2.0.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/amara-1.2.0.2.ebuild,v 1.2 2010/07/22 14:39:48 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_P="${P/amara/Amara}"
-
-DESCRIPTION="Python tools for XML processing."
-HOMEPAGE="http://uche.ogbuji.net/tech/4suite/amara/ http://pypi.python.org/pypi/Amara"
-SRC_URI="ftp://ftp.4suite.org/pub/Amara/${MY_P}.tar.bz2"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc examples"
-
-RDEPEND=">=dev-python/4suite-1.0.2"
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="ACKNOWLEDGEMENTS CHANGES README TODO docs/quickref.txt"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- epydoc build-$(PYTHON -f --ABI)/lib/amara || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r html/* || die "dohtml failed"
- fi
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r demo || die "doins failed"
- fi
-}
diff --git a/dev-python/amara/amara-2.0.0_alpha6.ebuild b/dev-python/amara/amara-2.0.0_alpha6.ebuild
new file mode 100644
index 000000000000..73ac902393b4
--- /dev/null
+++ b/dev-python/amara/amara-2.0.0_alpha6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/amara/amara-2.0.0_alpha6.ebuild,v 1.1 2012/05/16 09:39:14 dev-zero Exp $
+
+EAPI=4
+
+inherit distutils eutils
+
+MY_PN="Amara"
+MY_P="${MY_PN}-${PV/_alpha/a}"
+
+DESCRIPTION="Library for XML processing in Python."
+HOMEPAGE="http://wiki.xml3k.org/Amara2"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=dev-libs/expat-2.1.0-r2[unicode]
+ dev-lang/python[wide-unicode]
+ dev-python/html5lib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch \
+ "${FILESDIR}/${PV}-unbundle-expat.patch" \
+ "${FILESDIR}/${PV}-unbundle-python-libs.patch"
+}
+
+src_install() {
+ DOCS="CHANGES"
+
+ distutils_src_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo
+ fi
+}
diff --git a/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch b/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch
new file mode 100644
index 000000000000..5a82e6f7f1b8
--- /dev/null
+++ b/dev-python/amara/files/2.0.0_alpha6-unbundle-expat.patch
@@ -0,0 +1,45 @@
+diff --git a/lib/src/expat/expat.c b/lib/src/expat/expat.c
+index 4a9bf65..8e8e0a5 100644
+--- a/lib/src/expat/expat.c
++++ b/lib/src/expat/expat.c
+@@ -64,7 +64,7 @@ Expat wrapper library";
+ #define XmlString_SHARED
+ #include "xmlstring.h"
+ #include "cStringIO.h"
+-#include "lib/expat.h" /* Expat library */
++#include <expat.h> /* Expat library */
+ #include "xmlchar.h" /* XML_Char to PyUnicode support */
+ #include "stack.h" /* Stack_* routines */
+ #include "hash_table.h" /* XML_Char-keyed HashTable */
+diff --git a/lib/src/expat/xmlchar.h b/lib/src/expat/xmlchar.h
+index c1378b0..be4f3ac 100644
+--- a/lib/src/expat/xmlchar.h
++++ b/lib/src/expat/xmlchar.h
+@@ -6,7 +6,7 @@ extern "C" {
+ #endif
+
+ #include "Python.h"
+-#include "lib/expat_external.h"
++#include <expat_external.h>
+
+ #ifndef XML_UNICODE
+ #error ExpatReader requires a Unicode-enabled Expat
+diff --git a/setup.py b/setup.py
+index 6a0e650..f3856e3 100755
+--- a/setup.py
++++ b/setup.py
+@@ -303,12 +303,11 @@ setup(name='Amara',
+ Extension('amara._expat',
+ define_macros=[('HAVE_EXPAT_CONFIG_H', None),
+ ('Expat_BUILDING_MODULE', None),
++ ('XML_UNICODE_WCHAR_T', None),
+ ],
+ include_dirs=['lib/src', 'lib/src/expat'],
++ libraries=['expatw'],
+ sources=[# Expat XML parser
+- 'lib/src/expat/lib/xmlparse.c',
+- 'lib/src/expat/lib/xmlrole.c',
+- 'lib/src/expat/lib/xmltok.c',
+ # Miscellaneous supporting routines
+ 'lib/src/expat/util.c',
+ # XML_Char <-> PyUnicode
diff --git a/dev-python/amara/files/2.0.0_alpha6-unbundle-python-libs.patch b/dev-python/amara/files/2.0.0_alpha6-unbundle-python-libs.patch
new file mode 100644
index 000000000000..04f326ba7df9
--- /dev/null
+++ b/dev-python/amara/files/2.0.0_alpha6-unbundle-python-libs.patch
@@ -0,0 +1,32 @@
+diff --git a/lib/bindery/html.py b/lib/bindery/html.py
+index 0d1b953..d838982 100644
+--- a/lib/bindery/html.py
++++ b/lib/bindery/html.py
+@@ -13,7 +13,7 @@ import itertools
+ from functools import *
+ from itertools import *
+
+-from amara.thirdparty import html5lib
++import html5lib
+ from amara import tree
+ from amara.lib import inputsource
+ from amara.bindery import nodes
+diff --git a/setup.py b/setup.py
+index b6d0094..d3f8440 100755
+--- a/setup.py
++++ b/setup.py
+@@ -282,11 +282,6 @@ setup(name='Amara',
+ 'amara.xslt.tree',
+ 'amara.xslt.xpatterns',
+ 'amara.xupdate',
+- 'amara.thirdparty',
+- 'amara.thirdparty.httplib2',
+- 'amara.thirdparty.html5lib',
+- 'amara.thirdparty.html5lib.treebuilders',
+- # Test support; would be possible to break out into separate
+ # package at some point.
+ 'amara.test',
+ 'amara.test.xpath',
+--
+1.7.8.5
+