summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-12 07:36:30 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-12 07:36:30 +0000
commit0e2caafe922ccae6a1ec4bb928deb60db58da6b1 (patch)
treeaf9d2dfc3f852e67942d224d9a2ea6343be81dc7 /dev-python/apse
parentremove old (diff)
downloadgentoo-2-0e2caafe922ccae6a1ec4bb928deb60db58da6b1.tar.gz
gentoo-2-0e2caafe922ccae6a1ec4bb928deb60db58da6b1.tar.bz2
gentoo-2-0e2caafe922ccae6a1ec4bb928deb60db58da6b1.zip
Revbump. Don't install tests. Added src_test. swig is not a runtime dependency, bug 221469. Use DOCS to install docs. Drop old.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-python/apse')
-rw-r--r--dev-python/apse/ChangeLog9
-rw-r--r--dev-python/apse/apse-0.2-r1.ebuild28
-rw-r--r--dev-python/apse/apse-0.2.ebuild29
3 files changed, 36 insertions, 30 deletions
diff --git a/dev-python/apse/ChangeLog b/dev-python/apse/ChangeLog
index 5a79be28c1a2..5f66077bcd77 100644
--- a/dev-python/apse/ChangeLog
+++ b/dev-python/apse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/apse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/ChangeLog,v 1.8 2008/03/14 10:37:59 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/ChangeLog,v 1.9 2008/05/12 07:36:30 hawking Exp $
+
+*apse-0.2-r1 (12 May 2008)
+
+ 12 May 2008; Ali Polatel <hawking@gentoo.org> -apse-0.2.ebuild,
+ +apse-0.2-r1.ebuild:
+ Revbump. Don't install tests. Added src_test. swig is not a runtime
+ dependency, bug 221469. Use DOCS to install docs. Drop old.
14 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Christian Andreetta (satya, #48841) from metadata.xml.
diff --git a/dev-python/apse/apse-0.2-r1.ebuild b/dev-python/apse/apse-0.2-r1.ebuild
new file mode 100644
index 000000000000..4c2ad575ba3a
--- /dev/null
+++ b/dev-python/apse/apse-0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/apse-0.2-r1.ebuild,v 1.1 2008/05/12 07:36:30 hawking Exp $
+
+inherit distutils
+MY_PN="${PN/apse/Apse}"
+
+DESCRIPTION="Approximate String Matching in Python."
+HOMEPAGE="http://www.personal.psu.edu/staff/i/u/iua1/python/apse/"
+SRC_URI="http://www.personal.psu.edu/staff/i/u/iua1/python/${PN}/dist/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/swig"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+PYTHON_MODNAME="Apse"
+DOCS="README* *agrep"
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib.*)" ${python} test/test_Apse.py ||\
+  die "tests failed."
+}
diff --git a/dev-python/apse/apse-0.2.ebuild b/dev-python/apse/apse-0.2.ebuild
deleted file mode 100644
index 89b457df5a9f..000000000000
--- a/dev-python/apse/apse-0.2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apse/apse-0.2.ebuild,v 1.8 2007/07/11 06:19:48 mr_bones_ Exp $
-
-inherit distutils
-MY_PN="${PN/apse/Apse}"
-
-DESCRIPTION="Approximate String Matching in Python."
-HOMEPAGE="http://www.personal.psu.edu/staff/i/u/iua1/python/apse/"
-SRC_URI="http://www.personal.psu.edu/staff/i/u/iua1/python/apse/dist/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-lang/python
- dev-lang/swig"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-PYTHON_MODNAME="Apse"
-
-src_install() {
- distutils_src_install
- dodoc README* *agrep
- insinto /usr/share/doc/${PF}/test
- doins test/*
-}