summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-12-13 11:21:40 +0000
committerAlin Năstac <mrness@gentoo.org>2008-12-13 11:21:40 +0000
commit7fb77686e29dcc63aed30972baa51a03f83c862d (patch)
treeb4fc25ece21ad21a9268495dd9ee2bdd35f1e21d /dev-python/apsw/apsw-3.6.6.2.1.ebuild
parentStable on sparc, security bug #250314 (diff)
downloadgentoo-2-7fb77686e29dcc63aed30972baa51a03f83c862d.tar.gz
gentoo-2-7fb77686e29dcc63aed30972baa51a03f83c862d.tar.bz2
gentoo-2-7fb77686e29dcc63aed30972baa51a03f83c862d.zip
Version bump that compiles successfully with sqlite-3.6.6.2 (#250685).
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-python/apsw/apsw-3.6.6.2.1.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.6.6.2.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/apsw/apsw-3.6.6.2.1.ebuild b/dev-python/apsw/apsw-3.6.6.2.1.ebuild
new file mode 100644
index 000000000000..b60c2bfb2475
--- /dev/null
+++ b/dev-python/apsw/apsw-3.6.6.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.6.6.2.1.ebuild,v 1.1 2008/12/13 11:21:40 mrness Exp $
+
+inherit distutils versionator
+
+MY_PV=$(replace_version_separator 4 -r)
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="http://code.google.com/p/apsw/"
+SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/python
+ >=dev-db/sqlite-3.6.6.2"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ distutils_src_compile --omit=LOAD_EXTENSION
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/_sources/*
+ dohtml -r doc/*
+}
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib.*)" "${python}" tests.py || die "tests failed"
+}