summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-12 01:12:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-12 01:12:17 +0000
commit255e379982c59e88ffdf8bb82f460254cd181a2b (patch)
treeaba48083ff59b8f0dc59aafb47af9df4558bc8d8 /dev-python/arrayterator
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-255e379982c59e88ffdf8bb82f460254cd181a2b.tar.gz
gentoo-2-255e379982c59e88ffdf8bb82f460254cd181a2b.tar.bz2
gentoo-2-255e379982c59e88ffdf8bb82f460254cd181a2b.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/arrayterator')
-rw-r--r--dev-python/arrayterator/ChangeLog10
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild29
2 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/arrayterator/ChangeLog b/dev-python/arrayterator/ChangeLog
index da0456aaa268..4ce45701e531 100644
--- a/dev-python/arrayterator/ChangeLog
+++ b/dev-python/arrayterator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/arrayterator
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/ChangeLog,v 1.4 2010/07/09 22:20:03 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/ChangeLog,v 1.5 2013/02/12 01:12:17 mgorny Exp $
+
+*arrayterator-1.0.1-r1 (12 Feb 2013)
+
+ 12 Feb 2013; Michał Górny <mgorny@gentoo.org> +arrayterator-1.0.1-r1.ebuild:
+ Migrate to distutils-r1.
09 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
arrayterator-1.0.1.ebuild:
@@ -21,4 +26,3 @@
03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+arrayterator-1.0.ebuild:
Initial import. Based on an ebuild by Tim Cera. Closes #152284
-
diff --git a/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..75e5b898f925
--- /dev/null
+++ b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild,v 1.1 2013/02/12 01:12:17 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A buffered iterator for reading big arrays in small contiguous blocks"
+HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/numpy-1.0_rc1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd tests || die
+
+ "${PYTHON}" -c "import test_stochastic; test_stochastic.test()" \
+ || die "Tests fail with ${EPYTHON}"
+}