summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-24 17:06:55 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-24 17:06:55 +0000
commit333192fb9a551b230fc84f07367c4d7dd3c66b81 (patch)
tree14d5d36e2b2cde3649551b8e31afc50c37546db7 /dev-python/authres
parentStable for amd64, wrt bug #412565 (diff)
downloadgentoo-2-333192fb9a551b230fc84f07367c4d7dd3c66b81.tar.gz
gentoo-2-333192fb9a551b230fc84f07367c4d7dd3c66b81.tar.bz2
gentoo-2-333192fb9a551b230fc84f07367c4d7dd3c66b81.zip
Version bump, thanks to Marienz and Arfrever for suggestions regarding src_test()
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/ChangeLog8
-rw-r--r--dev-python/authres/authres-0.401.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/authres/ChangeLog b/dev-python/authres/ChangeLog
index d96d827b24ef..9a20b45e1742 100644
--- a/dev-python/authres/ChangeLog
+++ b/dev-python/authres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/authres
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.2 2012/04/24 11:32:18 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/ChangeLog,v 1.3 2012/04/24 17:06:55 xarthisius Exp $
+
+*authres-0.401 (24 Apr 2012)
+
+ 24 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org> +authres-0.401.ebuild:
+ Version bump, thanks to Marienz and Arfrever for suggestions regarding
+ src_test()
24 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org> authres-0.3.ebuild:
Fix PYTHON_MODNAME
diff --git a/dev-python/authres/authres-0.401.ebuild b/dev-python/authres/authres-0.401.ebuild
new file mode 100644
index 000000000000..4ea4105ece94
--- /dev/null
+++ b/dev-python/authres/authres-0.401.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/authres/authres-0.401.ebuild,v 1.1 2012/04/24 17:06:55 xarthisius Exp $
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5"
+
+inherit distutils
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python http://pypi.python.org/pypi/authres"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+PYTHON_MODNAME=${PN}.py
+DOCS="CHANGES README"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" \
+ -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || return
+ }
+ python_execute_function testing
+}