summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-05 17:47:08 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-05 17:47:08 +0000
commitd98d8b448373e990f1bf83c9c0ef079bbd19e599 (patch)
tree1a90f313f9caddcd099ef17b75d60759a6da25d3 /dev-python/autopep8/autopep8-0.5.2-r1.ebuild
parentalpha/ia64/s390/sh/sparc stable wrt #403843 (diff)
downloadgentoo-2-d98d8b448373e990f1bf83c9c0ef079bbd19e599.tar.gz
gentoo-2-d98d8b448373e990f1bf83c9c0ef079bbd19e599.tar.bz2
gentoo-2-d98d8b448373e990f1bf83c9c0ef079bbd19e599.zip
Remove unnecessary _p1 version and do a simple revbump instead. Add python herd to metadata
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/autopep8/autopep8-0.5.2-r1.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-0.5.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-0.5.2-r1.ebuild b/dev-python/autopep8/autopep8-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..a1794f498dd9
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.5.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.5.2-r1.ebuild,v 1.1 2012/05/05 17:47:08 xarthisius Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5-cpython"
+
+inherit eutils distutils
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pep8
+ dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="${PN}.py"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-issue-10.patch
+ distutils_src_prepare
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
+ }
+ python_execute_function testing
+}