summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 09:46:05 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 09:46:05 +0000
commit373f652b1f1709e2897775bbadcde3181dd7ecc9 (patch)
tree6ca96578bc09e61b5b2ba1dcb84842dbfe54bb1f /dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
parentgames herd (diff)
downloadgentoo-2-373f652b1f1709e2897775bbadcde3181dd7ecc9.tar.gz
gentoo-2-373f652b1f1709e2897775bbadcde3181dd7ecc9.tar.bz2
gentoo-2-373f652b1f1709e2897775bbadcde3181dd7ecc9.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
new file mode 100644
index 000000000000..e2a884eeddbb
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.7.ebuild,v 1.1 2008/06/25 09:46:05 hawking Exp $
+
+NEED_PYTHON="2.3"
+
+inherit distutils
+
+MY_PN=BeautifulSoup
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/${MY_P}.tar.gz"
+LICENSE="PSF-2.3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ PYTHONPATH="." "${python}" BeautifulSoupTests.py || die "tests failed"
+}