summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-02-10 10:17:56 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-02-10 10:17:56 +0000
commitab7ae6f1676c3764de710f2dc7670bc2943ec654 (patch)
tree694c070470ab0341da39a907578a1311fb81b576 /dev-python/bitstring
parentNew package wrt bug #402473. Initial ebuild by Chris Reffett <geekboy72@gmail... (diff)
downloadgentoo-2-ab7ae6f1676c3764de710f2dc7670bc2943ec654.tar.gz
gentoo-2-ab7ae6f1676c3764de710f2dc7670bc2943ec654.tar.bz2
gentoo-2-ab7ae6f1676c3764de710f2dc7670bc2943ec654.zip
Version bump
(Portage version: 2.2.0_alpha85/cvs/Linux i686)
Diffstat (limited to 'dev-python/bitstring')
-rw-r--r--dev-python/bitstring/ChangeLog9
-rw-r--r--dev-python/bitstring/bitstring-3.0.2.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/bitstring/ChangeLog b/dev-python/bitstring/ChangeLog
index 1cf9f6a3d5e4..6578fba036fe 100644
--- a/dev-python/bitstring/ChangeLog
+++ b/dev-python/bitstring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bitstring
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/ChangeLog,v 1.5 2011/11/22 13:26:10 grozin Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/ChangeLog,v 1.6 2012/02/10 10:17:56 grozin Exp $
+
+*bitstring-3.0.2 (10 Feb 2012)
+
+ 10 Feb 2012; Andrey Grozin <grozin@gentoo.org> +bitstring-3.0.2.ebuild:
+ Version bump
*bitstring-3.0.1 (22 Nov 2011)
diff --git a/dev-python/bitstring/bitstring-3.0.2.ebuild b/dev-python/bitstring/bitstring-3.0.2.ebuild
new file mode 100644
index 000000000000..8dd681ce1751
--- /dev/null
+++ b/dev-python/bitstring/bitstring-3.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bitstring/bitstring-3.0.2.ebuild,v 1.1 2012/02/10 10:17:56 grozin Exp $
+
+EAPI=3
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS=1
+inherit distutils
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="http://python-bitstring.googlecode.com/"
+SRC_URI="http://python-bitstring.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+
+src_test() {
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" test_${PN}.py
+ }
+ pushd test > /dev/null
+ python_execute_function testing
+ popd > /dev/null
+}