summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-04-09 02:33:49 +0000
committerMike Gilbert <floppym@gentoo.org>2014-04-09 02:33:49 +0000
commit3dfe6d65f6a455ab71436b77412915dc9e7db5b6 (patch)
tree00900e15513d774d520288b11d27b47fd9ba6f2f /dev-python/cffi
parentReplace pointless calls to python_gen_usedep with PYTHON_USEDEP. (diff)
downloadgentoo-2-3dfe6d65f6a455ab71436b77412915dc9e7db5b6.tar.gz
gentoo-2-3dfe6d65f6a455ab71436b77412915dc9e7db5b6.tar.bz2
gentoo-2-3dfe6d65f6a455ab71436b77412915dc9e7db5b6.zip
Add || die to python_test.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/ChangeLog6
-rw-r--r--dev-python/cffi/cffi-0.8.1.ebuild4
-rw-r--r--dev-python/cffi/cffi-0.8.2.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index a56c641d4479..a499a412a822 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.30 2014/04/02 20:58:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.31 2014/04/09 02:33:49 floppym Exp $
+
+ 09 Apr 2014; Mike Gilbert <floppym@gentoo.org> cffi-0.8.1.ebuild,
+ cffi-0.8.2.ebuild:
+ Add || die to python_test.
02 Apr 2014; Tim Harder <radhermit@gentoo.org> cffi-0.8.2.ebuild:
Add python3_4 support.
diff --git a/dev-python/cffi/cffi-0.8.1.ebuild b/dev-python/cffi/cffi-0.8.1.ebuild
index a94765154785..d2e4f46d8f95 100644
--- a/dev-python/cffi/cffi-0.8.1.ebuild
+++ b/dev-python/cffi/cffi-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.9 2014/03/31 20:41:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.1.ebuild,v 1.10 2014/04/09 02:33:49 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
@@ -26,7 +26,7 @@ python_compile_all() {
}
python_test() {
- py.test -x -v --ignore testing/test_zintegration.py c/ testing/
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
diff --git a/dev-python/cffi/cffi-0.8.2.ebuild b/dev-python/cffi/cffi-0.8.2.ebuild
index cdf92521b790..2580c1a3aaea 100644
--- a/dev-python/cffi/cffi-0.8.2.ebuild
+++ b/dev-python/cffi/cffi-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.2.ebuild,v 1.3 2014/04/02 20:58:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.8.2.ebuild,v 1.4 2014/04/09 02:33:49 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
@@ -26,7 +26,7 @@ python_compile_all() {
}
python_test() {
- py.test -x -v --ignore testing/test_zintegration.py c/ testing/
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
}
python_install_all() {