summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-22 07:01:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-22 07:01:30 +0000
commite2aa768eb655b8a0c3a2942f1f9e828a9be9e278 (patch)
tree1d69e8e0aee3d98a969f5dd80e3a7c9f2c6fd048 /dev-python/colander
parentbump (diff)
downloadgentoo-2-e2aa768eb655b8a0c3a2942f1f9e828a9be9e278.tar.gz
gentoo-2-e2aa768eb655b8a0c3a2942f1f9e828a9be9e278.tar.bz2
gentoo-2-e2aa768eb655b8a0c3a2942f1f9e828a9be9e278.zip
Bump
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/colander')
-rw-r--r--dev-python/colander/ChangeLog9
-rw-r--r--dev-python/colander/colander-1.0_alpha1.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/colander/ChangeLog b/dev-python/colander/ChangeLog
index 6ab71e5962b3..1a8787ecc05a 100644
--- a/dev-python/colander/ChangeLog
+++ b/dev-python/colander/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/colander
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.8 2012/10/09 09:17:59 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.9 2013/01/22 07:01:30 patrick Exp $
+
+*colander-1.0_alpha1 (22 Jan 2013)
+
+ 22 Jan 2013; Patrick Lauer <patrick@gentoo.org> +colander-1.0_alpha1.ebuild:
+ Bump
*colander-0.9.9 (09 Oct 2012)
diff --git a/dev-python/colander/colander-1.0_alpha1.ebuild b/dev-python/colander/colander-1.0_alpha1.ebuild
new file mode 100644
index 000000000000..9e6fa105fa0e
--- /dev/null
+++ b/dev-python/colander/colander-1.0_alpha1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-1.0_alpha1.ebuild,v 1.1 2013/01/22 07:01:30 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.6 3:3.2"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1"
+DISTUTILS_SRC_TEST=nosetests
+
+inherit distutils
+
+DESCRIPTION="A simple schema-based serialization and deserialization library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ http://pypi.python.org/pypi/colander"
+MY_P=${P/_alpha1/a1}
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+# MIT license is used by included (modified) iso8601.py code.
+LICENSE="repoze MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# Depend on an ebuild of translationstring with Python 3 support.
+RDEPEND=">=dev-python/translationstring-1.1"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Remove pylons theme since it's not included in source
+ sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ # https://github.com/Pylons/colander/issues/38
+ PYTHONPATH="." emake -C docs html SPHINXOPTS=""
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+}