summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-19 15:16:09 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-19 15:16:09 +0000
commit6afbff4f600227773f88938157a14b848717bfb5 (patch)
treedc65bdd59be81d96754a00f7e1b5482502e47cc8 /dev-python/coverage
parentclean old python impls, add pypy3 support (diff)
downloadgentoo-2-6afbff4f600227773f88938157a14b848717bfb5.tar.gz
gentoo-2-6afbff4f600227773f88938157a14b848717bfb5.tar.bz2
gentoo-2-6afbff4f600227773f88938157a14b848717bfb5.zip
clean old python impls, add pypy3 support
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/ChangeLog5
-rw-r--r--dev-python/coverage/coverage-3.7.1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/coverage/ChangeLog b/dev-python/coverage/ChangeLog
index 929da7875d58..f56393c28b99 100644
--- a/dev-python/coverage/ChangeLog
+++ b/dev-python/coverage/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/coverage
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/ChangeLog,v 1.120 2014/11/11 11:14:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/ChangeLog,v 1.121 2014/11/19 15:16:09 idella4 Exp $
+
+ 19 Nov 2014; Ian Delaney <idella4@gentoo.org> coverage-3.7.1.ebuild:
+ clean old python impls, add pypy3 support
11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> coverage-3.7.1.ebuild:
Stable for ia64, wrt bug #524416
diff --git a/dev-python/coverage/coverage-3.7.1.ebuild b/dev-python/coverage/coverage-3.7.1.ebuild
index 04e1385dac33..61373fb78d1b 100644
--- a/dev-python/coverage/coverage-3.7.1.ebuild
+++ b/dev-python/coverage/coverage-3.7.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.7.1.ebuild,v 1.12 2014/11/11 11:14:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/coverage/coverage-3.7.1.ebuild,v 1.13 2014/11/19 15:16:09 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Code coverage measurement for Python"
@@ -20,7 +20,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
python_compile() {
- if [[ ${EPYTHON} == python2.[67] ]]; then
+ if [[ ${EPYTHON} == python2.7 ]]; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
export CFLAGS
fi