summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-09 17:56:44 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-09 17:56:44 +0000
commiteaa543c14f680338f2cff7e27a4278f1c94d76f7 (patch)
treed2ef2ee8b28c0c6ea4ce953272485f843d00c032 /dev-python/cython
parentRequire >=python-2.6.5 for bug #456236. (diff)
downloadgentoo-2-eaa543c14f680338f2cff7e27a4278f1c94d76f7.tar.gz
gentoo-2-eaa543c14f680338f2cff7e27a4278f1c94d76f7.tar.bz2
gentoo-2-eaa543c14f680338f2cff7e27a4278f1c94d76f7.zip
Use sphinx-generated docs and remove outdated examples. Adjust description to match one used upstream. Fix install phase. Suggestions were from bug #456318.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/ChangeLog6
-rw-r--r--dev-python/cython/cython-0.18-r1.ebuild31
2 files changed, 18 insertions, 19 deletions
diff --git a/dev-python/cython/ChangeLog b/dev-python/cython/ChangeLog
index 048c46bdac4d..8416216687f5 100644
--- a/dev-python/cython/ChangeLog
+++ b/dev-python/cython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.89 2013/02/09 12:46:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/ChangeLog,v 1.90 2013/02/09 17:56:44 mgorny Exp $
+
+ 09 Feb 2013; Michał Górny <mgorny@gentoo.org> cython-0.18-r1.ebuild:
+ Use sphinx-generated docs and remove outdated examples. Adjust description to
+ match one used upstream. Fix install phase. Suggestions were from bug #456318.
*cython-0.18-r1 (09 Feb 2013)
diff --git a/dev-python/cython/cython-0.18-r1.ebuild b/dev-python/cython/cython-0.18-r1.ebuild
index 1ee4298f22fa..ec6e4c266b91 100644
--- a/dev-python/cython/cython-0.18-r1.ebuild
+++ b/dev-python/cython/cython-0.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.18-r1.ebuild,v 1.1 2013/02/09 12:46:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.18-r1.ebuild,v 1.2 2013/02/09 17:56:44 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
@@ -10,17 +10,18 @@ inherit distutils-r1 flag-o-matic
MY_PN="Cython"
MY_P="${MY_PN}-${PV/_/}"
-DESCRIPTION="Compiler for writing C extensions for the Python language"
+DESCRIPTION="A Python to C compiler"
HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples numpy"
+IUSE="doc numpy"
-DEPEND="numpy? ( >=dev-python/numpy-1.6.1-r1[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="numpy? ( >=dev-python/numpy-1.6.1-r1[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_PN}-${PV%_*}"
@@ -37,24 +38,18 @@ python_compile() {
distutils-r1_python_compile
}
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
python_test() {
"${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
|| die "Tests fail with ${EPYTHON}"
}
python_install_all() {
- local DOCS=( README.txt ToDo.txt USAGE.txt )
-
- distutils-r1_python_install
+ local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
+ use doc && local HTML_DOCS=( docs/build/html/. )
- if use doc; then
- # "-A c" is for ignoring of "Doc/primes.c".
- dohtml -A c -r Doc/*
- fi
-
- if use examples; then
- docinto examples
- dodoc -r Demos/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
+ distutils-r1_python_install_all
}