summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-06 17:32:48 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-06 17:32:48 +0000
commitc375da6b0a036fe85dcb14632c0ad745d79b4138 (patch)
tree7d2fc28fc6f4ea99992b4e255d4578c2fe151691 /dev-python/dbus-python
parentia64/x86 stable (diff)
downloadgentoo-2-c375da6b0a036fe85dcb14632c0ad745d79b4138.tar.gz
gentoo-2-c375da6b0a036fe85dcb14632c0ad745d79b4138.tar.bz2
gentoo-2-c375da6b0a036fe85dcb14632c0ad745d79b4138.zip
generate .pyc/.pyo files properly (bug 176612)
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/ChangeLog7
-rw-r--r--dev-python/dbus-python/dbus-python-0.71.ebuild10
-rw-r--r--dev-python/dbus-python/dbus-python-0.80.2.ebuild22
-rw-r--r--dev-python/dbus-python/dbus-python-0.81.0.ebuild22
4 files changed, 40 insertions, 21 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 606cba742593..bd7837ffcd24 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.25 2007/06/22 18:27:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.26 2007/07/06 17:32:48 hawking Exp $
+
+ 06 Jul 2007; Ali Polatel <hawking@gentoo.org> dbus-python-0.71.ebuild,
+ dbus-python-0.80.2.ebuild, dbus-python-0.81.0.ebuild:
+ generate .pyc/.pyo files properly, use python & multilib instead of
+ distutils (bug 176612)
22 Jun 2007; Raúl Porcel <armin76@gentoo.org> dbus-python-0.80.2.ebuild:
alpha stable wrt #174810
diff --git a/dev-python/dbus-python/dbus-python-0.71.ebuild b/dev-python/dbus-python/dbus-python-0.71.ebuild
index 84292fc3d231..f9d24914cbc2 100644
--- a/dev-python/dbus-python/dbus-python-0.71.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.71.ebuild,v 1.13 2007/05/13 07:22:45 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.71.ebuild,v 1.14 2007/07/06 17:32:48 hawking Exp $
inherit distutils
@@ -19,10 +19,4 @@ RDEPEND=">=dev-lang/python-2.4
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_postrm() {
- python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/dbus
-}
-
-pkg_postinst() {
- python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/dbus
-}
+PYTHON_MODNAME="dbus"
diff --git a/dev-python/dbus-python/dbus-python-0.80.2.ebuild b/dev-python/dbus-python/dbus-python-0.80.2.ebuild
index 7809116f6ead..9ab7d5070075 100644
--- a/dev-python/dbus-python/dbus-python-0.80.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.80.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.80.2.ebuild,v 1.11 2007/06/24 21:33:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.80.2.ebuild,v 1.12 2007/07/06 17:32:48 hawking Exp $
-inherit distutils
+inherit python multilib
DESCRIPTION="Python bindings for the D-Bus messagebus."
HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
@@ -22,6 +22,16 @@ DEPEND="${RDEPEND}
test? ( dev-python/pygobject )
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ dbus/Makefile.in Makefile.in || die "sed in Makefile.in failed"
+}
+
src_compile() {
econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
emake || die "emake failed"
@@ -31,10 +41,10 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
}
-pkg_postrm() {
- python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/dbus
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/dbus
}
-pkg_postinst() {
- python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/dbus
+pkg_postrm() {
+ python_mod_cleanup
}
diff --git a/dev-python/dbus-python/dbus-python-0.81.0.ebuild b/dev-python/dbus-python/dbus-python-0.81.0.ebuild
index 4cab0baf9fcf..a63d1d66f3e8 100644
--- a/dev-python/dbus-python/dbus-python-0.81.0.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.81.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.81.0.ebuild,v 1.2 2007/06/22 18:27:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.81.0.ebuild,v 1.3 2007/07/06 17:32:48 hawking Exp $
-inherit distutils
+inherit python multilib
DESCRIPTION="Python bindings for the D-Bus messagebus."
HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
@@ -22,6 +22,16 @@ DEPEND="${RDEPEND}
test? ( dev-python/pygobject )
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't run py-compile
+ sed -i \
+ -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
+ dbus/Makefile.in Makefile.in || die "sed in Makefile.in failed"
+}
+
src_compile() {
econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
emake || die "emake failed"
@@ -31,10 +41,10 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
}
-pkg_postrm() {
- python_mod_cleanup "${ROOT}"/usr/lib/python*/site-packages/dbus
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python*/site-packages/dbus
}
-pkg_postinst() {
- python_mod_optimize "${ROOT}"/usr/lib/python*/site-packages/dbus
+pkg_postrm() {
+ python_mod_cleanup
}