summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-27 14:26:35 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-27 14:26:35 +0000
commit0fa8bcee95f461d3b0868b1d6c301e24b071a6d9 (patch)
tree9a79144afb330e9b1c213d81006844564b838868 /dev-python/diff-match-patch
parentVersion bump, drop old (diff)
downloadgentoo-2-0fa8bcee95f461d3b0868b1d6c301e24b071a6d9.tar.gz
gentoo-2-0fa8bcee95f461d3b0868b1d6c301e24b071a6d9.tar.bz2
gentoo-2-0fa8bcee95f461d3b0868b1d6c301e24b071a6d9.zip
dev-python/diff-match-patch: Ebuild clean up wrt test phase.
distutils eclass src_test() is used instead of custom one. Also distutils eclass src_prepare() is called at the beginning of custom one. (Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/diff-match-patch')
-rw-r--r--dev-python/diff-match-patch/ChangeLog9
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild16
2 files changed, 12 insertions, 13 deletions
diff --git a/dev-python/diff-match-patch/ChangeLog b/dev-python/diff-match-patch/ChangeLog
index 40ce9e97595e..4ffc30a28e98 100644
--- a/dev-python/diff-match-patch/ChangeLog
+++ b/dev-python/diff-match-patch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/diff-match-patch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/ChangeLog,v 1.1 2011/12/27 13:07:18 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/ChangeLog,v 1.2 2011/12/27 14:26:35 aidecoe Exp $
+
+ 27 Dec 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ diff-match-patch-20110725.1.ebuild:
+ Ebuild clean up wrt test phase.
+
+ distutils eclass src_test() is used instead of custom one. Also distutils
+ eclass src_prepare() is called at the beginning of custom one.
*diff-match-patch-20110725.1 (27 Dec 2011)
diff --git a/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild b/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild
index dd0c06cb0c9f..772e004af382 100644
--- a/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild
+++ b/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild,v 1.1 2011/12/27 13:07:18 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild,v 1.2 2011/12/27 14:26:35 aidecoe Exp $
EAPI=4
PYTHON_DEPEND="*"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
inherit distutils
@@ -21,25 +22,16 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
-TEST_SCRIPT="${PN//-/_}/${PN//-/_}_test.py"
-
src_prepare() {
+ distutils_src_prepare
python_convert_shebangs -r 2 python2/*
}
-src_test() {
- testing() {
- local pylib="build-${PYTHON_ABI}/lib"
- PYTHONPATH="${pylib}" "$(PYTHON)" "${pylib}/${TEST_SCRIPT}"
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
delete_tests() {
- rm "${D}/$(python_get_sitedir)/${TEST_SCRIPT}" || die
+ rm "${D}/$(python_get_sitedir)/${PN//-/_}/${PN//-/_}_test.py" || die
}
python_execute_function -q delete_tests