summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-25 17:43:54 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-25 17:43:54 +0000
commit75420b6fc9c1cc5b499c9dab626467dedf5cef11 (patch)
treeb703fa206f08eb93f4fc0bc93184f0040ebd77a5 /dev-python/django-setuptest
parentit builds fine now with -ggdb3, drop the replace-flags (diff)
downloadgentoo-2-75420b6fc9c1cc5b499c9dab626467dedf5cef11.tar.gz
gentoo-2-75420b6fc9c1cc5b499c9dab626467dedf5cef11.tar.bz2
gentoo-2-75420b6fc9c1cc5b499c9dab626467dedf5cef11.zip
bump, remove old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-setuptest')
-rw-r--r--dev-python/django-setuptest/ChangeLog8
-rw-r--r--dev-python/django-setuptest/django-setuptest-0.1.2.ebuild28
-rw-r--r--dev-python/django-setuptest/django-setuptest-0.1.4.ebuild25
3 files changed, 32 insertions, 29 deletions
diff --git a/dev-python/django-setuptest/ChangeLog b/dev-python/django-setuptest/ChangeLog
index 919d4f9fc311..bae0ab687ec4 100644
--- a/dev-python/django-setuptest/ChangeLog
+++ b/dev-python/django-setuptest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-setuptest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-setuptest/ChangeLog,v 1.2 2013/05/28 06:40:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-setuptest/ChangeLog,v 1.3 2013/06/25 17:43:54 idella4 Exp $
+
+*django-setuptest-0.1.4 (25 Jun 2013)
+
+ 25 Jun 2013; Ian Delaney <idella4@gentoo.org> +django-setuptest-0.1.4.ebuild,
+ -django-setuptest-0.1.2.ebuild:
+ bump, remove old
*django-setuptest-0.1.2-r1 (28 May 2013)
diff --git a/dev-python/django-setuptest/django-setuptest-0.1.2.ebuild b/dev-python/django-setuptest/django-setuptest-0.1.2.ebuild
deleted file mode 100644
index e0d872da9b81..000000000000
--- a/dev-python/django-setuptest/django-setuptest-0.1.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-setuptest/django-setuptest-0.1.2.ebuild,v 1.1 2012/11/18 12:24:13 idella4 Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS=1
-inherit distutils
-
-MY_PN="praekelt-${P}-O-g86Offe9"
-MY_P="praekelt-${PN}-860ffe9"
-DESCRIPTION="Simple test suite enabling Django app testing via setup.py"
-HOMEPAGE="https://github.com/praekelt/django-setuptest"
-SRC_URI="https://github.com/praekelt/${PN}/zipball/master/${MY_PN}.zip"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/pep8
- dev-python/coverage"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/django-setuptest/django-setuptest-0.1.4.ebuild b/dev-python/django-setuptest/django-setuptest-0.1.4.ebuild
new file mode 100644
index 000000000000..cbda419a631a
--- /dev/null
+++ b/dev-python/django-setuptest/django-setuptest-0.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-setuptest/django-setuptest-0.1.4.ebuild,v 1.1 2013/06/25 17:43:54 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple test suite enabling Django app testing via setup.py"
+HOMEPAGE="https://github.com/praekelt/django-setuptest"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"