summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-28 21:32:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-28 21:32:36 +0000
commit57ad0a334c9e345b696828acc9c6698f49de2902 (patch)
treef9573b1e8bec5b374f31731b9c1201a0376d4180 /dev-python/dnspython/dnspython-1.9.4.ebuild
parentMissing die, minor clean up (diff)
downloadgentoo-2-57ad0a334c9e345b696828acc9c6698f49de2902.tar.gz
gentoo-2-57ad0a334c9e345b696828acc9c6698f49de2902.tar.bz2
gentoo-2-57ad0a334c9e345b696828acc9c6698f49de2902.zip
Version bump.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/dnspython/dnspython-1.9.4.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.9.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.9.4.ebuild b/dev-python/dnspython/dnspython-1.9.4.ebuild
new file mode 100644
index 000000000000..e807fdbda04f
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.9.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.9.4.ebuild,v 1.1 2011/03/28 21:32:35 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+DEPEND="dev-python/pycrypto"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README TODO"
+PYTHON_MODNAME="dns"
+
+src_test() {
+ cd tests
+
+ testing() {
+ local exit_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || exit_status="1"
+ done
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die "Installation of examples failed"
+ fi
+}