summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:32:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:32:25 +0000
commit67c24b6fec69e22f9ec24d74af227495c2579206 (patch)
treec8a47c3780c46394c5fc48788453654337bd5b00 /dev-python/elixir
parentFix LICENSE (#301969). Maintenance (diff)
downloadgentoo-2-67c24b6fec69e22f9ec24d74af227495c2579206.tar.gz
gentoo-2-67c24b6fec69e22f9ec24d74af227495c2579206.tar.bz2
gentoo-2-67c24b6fec69e22f9ec24d74af227495c2579206.zip
Use $(PYTHON -f) instead of ${python}.
(Portage version: 15324-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/elixir')
-rw-r--r--dev-python/elixir/elixir-0.7.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/elixir/elixir-0.7.1.ebuild b/dev-python/elixir/elixir-0.7.1.ebuild
index f964751669f8..52322d2d07dd 100644
--- a/dev-python/elixir/elixir-0.7.1.ebuild
+++ b/dev-python/elixir/elixir-0.7.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.7.1.ebuild,v 1.1 2009/12/21 06:37:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.7.1.ebuild,v 1.2 2010/02/06 14:32:25 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -36,10 +37,9 @@ src_compile() {
distutils_src_compile
if use doc; then
- python_version
einfo "Generation of documentation"
- "${python}" setup.py addcommand -p buildutils.pudge_command
- PYTHONPATH=. "${python}" setup.py pudge || die "Generation of documentation failed"
+ "$(PYTHON -f)" setup.py addcommand -p buildutils.pudge_command
+ PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "Generation of documentation failed"
fi
}