summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-09-30 03:47:41 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-09-30 03:47:41 +0000
commit9aa4c2003529db808b4b9c46f549e7472a460961 (patch)
treeaa2a392a4630451056e3223f36c7daf3d877f207 /dev-python/elixir
parentFix GCC 4.3 build error w/ USE="jingle". Patch from devsk in bug #223535. (diff)
downloadgentoo-2-9aa4c2003529db808b4b9c46f549e7472a460961.tar.gz
gentoo-2-9aa4c2003529db808b4b9c46f549e7472a460961.tar.bz2
gentoo-2-9aa4c2003529db808b4b9c46f549e7472a460961.zip
Version bump. Removed older version
(Portage version: 2.2_rc8/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/elixir')
-rw-r--r--dev-python/elixir/ChangeLog8
-rw-r--r--dev-python/elixir/elixir-0.6.1.ebuild (renamed from dev-python/elixir/elixir-0.3.0.ebuild)19
2 files changed, 13 insertions, 14 deletions
diff --git a/dev-python/elixir/ChangeLog b/dev-python/elixir/ChangeLog
index 1666d264c48b..3112c160c39c 100644
--- a/dev-python/elixir/ChangeLog
+++ b/dev-python/elixir/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/elixir
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/ChangeLog,v 1.4 2008/07/17 17:32:22 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/ChangeLog,v 1.5 2008/09/30 03:47:41 neurogeek Exp $
+
+*elixir-0.6.1 (30 Sep 2008)
+
+ 30 Sep 2008; Jesus Rivero <neurogeek@gentoo.org> -elixir-0.3.0.ebuild,
+ +elixir-0.6.1.ebuild:
+ Version bump. Removed older version
17 Jul 2008; Ali Polatel <hawking@gentoo.org> elixir-0.5.2.ebuild:
Update sqlalchemy dependency, #232073
diff --git a/dev-python/elixir/elixir-0.3.0.ebuild b/dev-python/elixir/elixir-0.6.1.ebuild
index 1a473f8ec6f9..33ee0be91c85 100644
--- a/dev-python/elixir/elixir-0.3.0.ebuild
+++ b/dev-python/elixir/elixir-0.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.3.0.ebuild,v 1.1 2007/07/31 13:09:05 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.6.1.ebuild,v 1.1 2008/09/30 03:47:41 neurogeek Exp $
NEED_PYTHON=2.4
@@ -18,7 +18,7 @@ LICENSE="MIT"
SLOT="0"
IUSE="doc examples test"
-RDEPEND=">=dev-python/sqlalchemy-0.3.0"
+RDEPEND=">=dev-python/sqlalchemy-0.4.0"
DEPEND="${RDEPEND}
dev-python/setuptools
doc? ( >=dev-python/docutils-0.4-r3
@@ -26,30 +26,23 @@ DEPEND="${RDEPEND}
>=dev-python/kid-0.9
>=dev-python/pygments-0.8.1
>=dev-python/pudge-0.1.3
- >=dev-python/buildutils-0.1.2 )
+ >=dev-python/buildutils-0.3 )
test? ( dev-python/nose )"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- distutils_src_unpack
-
- # The following tests are broken in this version
- cd "${S}/tests"
- rm test_inherit.py test_oneway.py test_order_by.py test_movies.py
-}
-
src_compile() {
distutils_src_compile
if use doc ; then
einfo "Generating docs as requested..."
+ ${python} setup.py addcommand -p buildutils.pudge_command
PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
fi
}
src_install() {
distutils_src_install
- use doc && dohtml -r docs/html/*
+ use doc && dohtml -r build/doc/*
if use examples ; then
insinto /usr/share/doc/${PF}
doins -r examples