summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:24:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:24:27 +0000
commit4d3e064b647ab25ca0f47e386f2d3ad2c02967ac (patch)
tree3f2722029930b55ea8c98cb379e0eb5460e79da1 /dev-python/enable
parentInitial import (diff)
downloadgentoo-2-4d3e064b647ab25ca0f47e386f2d3ad2c02967ac.tar.gz
gentoo-2-4d3e064b647ab25ca0f47e386f2d3ad2c02967ac.tar.bz2
gentoo-2-4d3e064b647ab25ca0f47e386f2d3ad2c02967ac.zip
Initial import
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog10
-rw-r--r--dev-python/enable/enable-3.0.2.ebuild59
-rw-r--r--dev-python/enable/files/enable-3.0.2-nofreetype.patch99
-rw-r--r--dev-python/enable/metadata.xml12
4 files changed, 180 insertions, 0 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
new file mode 100644
index 000000000000..e5d07fbd72cb
--- /dev/null
+++ b/dev-python/enable/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/enable
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.1 2009/01/15 10:24:27 bicatali Exp $
+
+*enable-3.0.2 (15 Jan 2009)
+
+ 15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/enable-3.0.2-nofreetype.patch, +metadata.xml, +enable-3.0.2.ebuild:
+ Initial import
+
diff --git a/dev-python/enable/enable-3.0.2.ebuild b/dev-python/enable/enable-3.0.2.ebuild
new file mode 100644
index 000000000000..d78a4ae3f0f8
--- /dev/null
+++ b/dev-python/enable/enable-3.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.0.2.ebuild,v 1.1 2009/01/15 10:24:27 bicatali Exp $
+
+EAPI=2
+inherit eutils distutils
+
+MY_PN="Enable"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Enthought Tools Suite drawing and interaction GUI objects"
+HOMEPAGE="http://code.enthought.com/projects/enable"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND=">=dev-python/numpy-1.1
+ dev-python/reportlab
+ dev-python/traitsgui
+ >=media-libs/freetype-2
+ virtual/glu
+ x11-libs/libX11"
+
+DEPEND="dev-python/setuptools
+ >=dev-python/numpy-1.1
+ >=media-libs/freetype-2
+ virtual/glu
+ x11-libs/libX11
+ dev-lang/swig
+ dev-python/pyrex
+ test? ( >=dev-python/nose-0.10.3
+ dev-python/enthoughtbase
+ dev-python/traitsgui[wxwindows] )"
+
+#tests need X
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nofreetype.patch
+ sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+}
+
+src_test() {
+ PYTHONPATH=$(dir -d build/lib*) ${python} setup.py test || die "tests failed"
+}
+
+src_install() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
diff --git a/dev-python/enable/files/enable-3.0.2-nofreetype.patch b/dev-python/enable/files/enable-3.0.2-nofreetype.patch
new file mode 100644
index 000000000000..53a6f8dffe9e
--- /dev/null
+++ b/dev-python/enable/files/enable-3.0.2-nofreetype.patch
@@ -0,0 +1,99 @@
+Index: python-enable-3.0.1/enthought/kiva/agg/setup.py
+===================================================================
+--- python-enable-3.0.1.orig/enthought/kiva/agg/setup.py 2008-09-27 00:07:39.000000000 -0400
++++ python-enable-3.0.1/enthought/kiva/agg/setup.py 2008-09-27 00:11:45.000000000 -0400
+@@ -5,39 +5,6 @@
+ import platform
+
+
+-
+-
+-freetype2_sources =['autohint/autohint.c',
+- 'base/ftbase.c','base/ftsystem.c','base/ftinit.c',
+- 'base/ftglyph.c','base/ftmm.c','base/ftbdf.c',
+- 'base/ftbbox.c','base/ftdebug.c','base/ftxf86.c',
+- 'base/fttype1.c','bdf/bdf.c',
+- 'cff/cff.c',
+- 'cid/type1cid.c',
+- 'pcf/pcf.c','pfr/pfr.c',
+- 'psaux/psaux.c',
+- 'pshinter/pshinter.c',
+- 'psnames/psnames.c',
+- 'raster/raster.c',
+- 'sfnt/sfnt.c',
+- 'smooth/smooth.c',
+- 'truetype/truetype.c',
+- 'type1/type1.c',
+- 'type42/type42.c',
+- 'winfonts/winfnt.c',
+- 'gzip/ftgzip.c',
+- 'base/ftmac.c',
+- ]
+-
+-freetype2_dirs = [
+- 'base','bdf','cache','cff','cid','pcf','pfr',
+- 'psaux','pshinter','psnames','raster','sfnt',
+- 'smooth','truetype','type1','type42','winfonts',
+- 'gzip'
+- ]
+-
+-
+-
+ def configuration(parent_package='',top_path=None):
+ from numpy.distutils.misc_util import Configuration
+ from numpy.distutils.system_info import dict_append, get_info
+@@ -68,35 +35,10 @@
+
+
+ #-------------------------------------------------------------------------
+- # Add the freetype library (agg 2.4 links against this)
+- #-------------------------------------------------------------------------
+-
+- prefix = config.paths('freetype2/src')[0]
+- freetype_lib = 'freetype2_src'
+-
+- def get_ft2_sources((lib_name, build_info), build_dir):
+- sources = [prefix + "/" + s for s in freetype2_sources]
+- if sys.platform=='darwin':
+- return sources[:]
+- return sources[:-1]
+-
+- ft2_incl_dirs = ['freetype2/src/' + s for s in freetype2_dirs] \
+- + ['freetype2/include', 'freetype2/src']
+- ft2_incl_dirs = config.paths(*ft2_incl_dirs)
+- if sys.platform == 'darwin':
+- ft2_incl_dirs.append("/Developer/Headers/FlatCarbon")
+-
+- config.add_library(freetype_lib,
+- sources = [get_ft2_sources],
+- include_dirs = ft2_incl_dirs,
+- depends = ['freetype2']
+- )
+-
+- #-------------------------------------------------------------------------
+ # Add the Agg sources
+ #-------------------------------------------------------------------------
+
+- agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ft2_incl_dirs
++ agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ["/usr/include/freetype2/"]
+ agg_sources = [agg_dir+'/src/*.cpp',
+ agg_dir+'/font_freetype/*.cpp']
+ config.add_library(agg_lib,
+@@ -110,7 +52,7 @@
+ if sys.platform == 'darwin':
+ define_macros = [('__DARWIN__', None)]
+ macros = [('__DARWIN__', None)]
+- extra_link_args = ['-framework', 'Carbon']
++ extra_link_args = ['-framework', 'Carbon', '-Wl,-search_paths_first']
+ else:
+ define_macros = []
+ macros = []
+@@ -163,7 +105,7 @@
+
+ build_info = {}
+ kiva_lib = 'kiva_src'
+- build_libraries = [kiva_lib, agg_lib, freetype_lib]
++ build_libraries = [kiva_lib, agg_lib, "freetype"]
+ if sys.platform == "win32":
+ build_libraries += ["opengl32", "glu32"]
+ elif sys.platform == "darwin":
diff --git a/dev-python/enable/metadata.xml b/dev-python/enable/metadata.xml
new file mode 100644
index 000000000000..b097092fd77d
--- /dev/null
+++ b/dev-python/enable/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The Enable project from the Enthought Tool Suite provides two
+ related multi-platform packages for drawing GUI objects:
+ * Enable: An object drawing library that supports containment and
+ event notification.
+ * Kiva: A multi-platform DisplayPDF vector drawing engine.
+ </longdescription>
+</pkgmetadata>