summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-14 13:43:09 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-14 13:43:09 +0000
commitd6e2c57d19350e793215b8144df4a1d8363d8c36 (patch)
tree7a5867c48f757e95abf4f4a12c25513d0e0ee409 /dev-python/enable
parentVersion bump, drop old (diff)
downloadgentoo-2-d6e2c57d19350e793215b8144df4a1d8363d8c36.tar.gz
gentoo-2-d6e2c57d19350e793215b8144df4a1d8363d8c36.tar.bz2
gentoo-2-d6e2c57d19350e793215b8144df4a1d8363d8c36.zip
bump; update SRC_URI, add missing test dep, fix qa issue in build, drop old patches, minor fix to doc build, upgrade test phase
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog10
-rw-r--r--dev-python/enable/enable-4.4.1.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index 34a5b24f20d2..de852f2301e3 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/enable
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.24 2013/05/14 13:57:21 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.25 2014/11/14 13:43:09 idella4 Exp $
+
+*enable-4.4.1 (14 Nov 2014)
+
+ 14 Nov 2014; Ian Delaney <idella4@gentoo.org> +enable-4.4.1.ebuild:
+ bump; update SRC_URI, add missing test dep, fix qa issue in build, drop old
+ patches, minor fix to doc build, upgrade test phase
*enable-4.3.0 (14 May 2013)
diff --git a/dev-python/enable/enable-4.4.1.ebuild b/dev-python/enable/enable-4.4.1.ebuild
new file mode 100644
index 000000000000..d58ebbdc94f0
--- /dev/null
+++ b/dev-python/enable/enable-4.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.4.1.ebuild,v 1.1 2014/11/14 13:43:09 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx flag-o-matic
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
+SRC_URI="https://github.com/enthought/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ >=media-libs/freetype-2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/swig
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+
+ sed -e 's:html_favicon = "et.ico":html_favicon = "_static/et.ico":' \
+ -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ # https://github.com/enthought/enable/issues/158
+ PYTHONPATH=.:kiva \
+ VIRTUALX_COMMAND="nosetests" virtualmake
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}