summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 15:31:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-05 15:31:52 +0000
commit0b9bd0cb99fab13b4545dc014696da731a0154c5 (patch)
tree3053bcfd52dca428a0536b4016de51031ab23427 /dev-python/enthoughtbase
parentBumping to 4.5.0, adding support for EAP modules and adding myself to the mai... (diff)
downloadgentoo-2-0b9bd0cb99fab13b4545dc014696da731a0154c5.tar.gz
gentoo-2-0b9bd0cb99fab13b4545dc014696da731a0154c5.tar.bz2
gentoo-2-0b9bd0cb99fab13b4545dc014696da731a0154c5.zip
Avoid test failure without sci-libs/scipy.
(Portage version: 2.2.0_alpha6_p21/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/enthoughtbase')
-rw-r--r--dev-python/enthoughtbase/ChangeLog6
-rw-r--r--dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/enthoughtbase/ChangeLog b/dev-python/enthoughtbase/ChangeLog
index 834582009a68..8a3fc1cec468 100644
--- a/dev-python/enthoughtbase/ChangeLog
+++ b/dev-python/enthoughtbase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/enthoughtbase
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.17 2010/10/18 12:40:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.18 2010/12/05 15:31:52 arfrever Exp $
+
+ 05 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ enthoughtbase-3.0.6.ebuild:
+ Avoid test failure without sci-libs/scipy.
*enthoughtbase-3.0.6 (18 Oct 2010)
diff --git a/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild b/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild
index 19b21b5041c8..7f09e3ee0058 100644
--- a/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild
+++ b/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild,v 1.1 2010/10/18 12:40:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.6.ebuild,v 1.2 2010/12/05 15:31:52 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -45,6 +45,11 @@ src_prepare() {
-e "s/self.run_command('build_docs')/pass/" \
-e "/setupdocs>=1.0/d" \
-i setup.py || die "sed setup.py failed"
+
+ if ! has_version sci-libs/scipy; then
+ # enthought/util/tests/test_numeric.py imports deprecated enthought.util.numeric module, which depends on scipy.
+ rm -f enthought/util/tests/test_numeric.py
+ fi
}
src_compile() {