summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-17 14:56:12 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-17 14:56:12 +0000
commit16cba3239afcc882bc414845024f183d8771eced (patch)
treeb35d759a2a30465505eeb5c1f427e4e54368183a /dev-python/flake8
parentImported from Perl overlay (diff)
downloadgentoo-2-16cba3239afcc882bc414845024f183d8771eced.tar.gz
gentoo-2-16cba3239afcc882bc414845024f183d8771eced.tar.bz2
gentoo-2-16cba3239afcc882bc414845024f183d8771eced.zip
revbump; set borders to versions in deps, fixes Bug #542984
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/ChangeLog8
-rw-r--r--dev-python/flake8/flake8-2.4.0-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
index d5594e8e90a7..3038063e60b9 100644
--- a/dev-python/flake8/ChangeLog
+++ b/dev-python/flake8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flake8
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.30 2015/03/09 21:26:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.31 2015/03/17 14:56:12 idella4 Exp $
+
+*flake8-2.4.0-r1 (17 Mar 2015)
+
+ 17 Mar 2015; Ian Delaney <idella4@gentoo.org> +flake8-2.4.0-r1.ebuild,
+ flake8-2.4.0.ebuild:
+ revbump; set borders to versions in deps, fixes Bug #542984
*flake8-2.1.0 (09 Mar 2015)
diff --git a/dev-python/flake8/flake8-2.4.0-r1.ebuild b/dev-python/flake8/flake8-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..bc76db69da5b
--- /dev/null
+++ b/dev-python/flake8/flake8-2.4.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.4.0-r1.ebuild,v 1.1 2015/03/17 14:56:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="http://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND=">=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ <dev-python/pep8-1.6.0[${PYTHON_USEDEP}]
+ "
+PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_prepare_all() {
+ # This tests requires / assumes this version is already installed.
+ sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}