summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-26 16:02:49 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-26 16:02:49 +0000
commit2b5063738226285fc97ffa70c43b6be564856cc6 (patch)
tree7096c1df52b98d1ba0315f25f7f0e1b145ce4d94 /dev-python/flake8
parentDrop old (diff)
downloadgentoo-2-2b5063738226285fc97ffa70c43b6be564856cc6.tar.gz
gentoo-2-2b5063738226285fc97ffa70c43b6be564856cc6.tar.bz2
gentoo-2-2b5063738226285fc97ffa70c43b6be564856cc6.zip
Version bump, drop python3_2 support.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/ChangeLog7
-rw-r--r--dev-python/flake8/flake8-2.2.5.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
index 13339566b3aa..b7c442c5742e 100644
--- a/dev-python/flake8/ChangeLog
+++ b/dev-python/flake8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flake8
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.17 2014/09/23 20:11:23 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.18 2014/10/26 16:02:49 radhermit Exp $
+
+*flake8-2.2.5 (26 Oct 2014)
+
+ 26 Oct 2014; Tim Harder <radhermit@gentoo.org> +flake8-2.2.5.ebuild:
+ Version bump, drop python3_2 support.
*flake8-2.0-r1 (23 Sep 2014)
diff --git a/dev-python/flake8/flake8-2.2.5.ebuild b/dev-python/flake8/flake8-2.2.5.ebuild
new file mode 100644
index 000000000000..30ad82341495
--- /dev/null
+++ b/dev-python/flake8/flake8-2.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.2.5.ebuild,v 1.1 2014/10/26 16:02:49 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="http://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND=">=dev-python/pyflakes-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
+PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # This tests requires / assumes this version is already installed.
+ sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}