summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-06 08:58:41 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-06 08:58:41 +0000
commit61c87073f0220ee78dd44d6a2e8b809dc579cccf (patch)
tree1f677476ebbb517241e51d77caeac4e0a1dec0a9 /dev-python/flake8
parentsci-chemistry/relax: Version Bump (diff)
downloadgentoo-2-61c87073f0220ee78dd44d6a2e8b809dc579cccf.tar.gz
gentoo-2-61c87073f0220ee78dd44d6a2e8b809dc579cccf.tar.bz2
gentoo-2-61c87073f0220ee78dd44d6a2e8b809dc579cccf.zip
add missing keyword, exclude rogue test, drop py2.6 add py3.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/ChangeLog5
-rw-r--r--dev-python/flake8/flake8-2.1.0.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
index 97abe78b0b96..fe0c33902835 100644
--- a/dev-python/flake8/ChangeLog
+++ b/dev-python/flake8/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/flake8
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.11 2014/05/04 16:16:02 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.12 2014/06/06 08:58:41 idella4 Exp $
+
+ 06 Jun 2014; Ian Delaney <idella4@gentoo.org> flake8-2.1.0.ebuild:
+ add missing keyword, exclude rogue test, drop py2.6 add py3.4
04 May 2014; Markus Meier <maekke@gentoo.org> flake8-2.0.ebuild:
add ~arm, bug #508282
diff --git a/dev-python/flake8/flake8-2.1.0.ebuild b/dev-python/flake8/flake8-2.1.0.ebuild
index 9ae1032bf643..ee60bd915408 100644
--- a/dev-python/flake8/flake8-2.1.0.ebuild
+++ b/dev-python/flake8/flake8-2.1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.1.0.ebuild,v 1.4 2014/04/25 14:24:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.1.0.ebuild,v 1.5 2014/06/06 08:58:41 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1
@@ -12,7 +12,7 @@ DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
HOMEPAGE="http://bitbucket.org/tarek/flake8"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
LICENSE="MIT"
SLOT="0"
@@ -27,6 +27,12 @@ DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # This tests requires / assumes this version is already installed.
+ sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
esetup.py test
}