summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-31 07:29:52 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-31 07:29:52 +0000
commit6d4c8101ca83a08a3d2af67cdda7312dce7b79cf (patch)
tree85cc8b3870937fd6087d91704de52c172b7b7047 /dev-python/flake8
parentadded apparent support of healthy py2.[5-6], py3.2 (diff)
downloadgentoo-2-6d4c8101ca83a08a3d2af67cdda7312dce7b79cf.tar.gz
gentoo-2-6d4c8101ca83a08a3d2af67cdda7312dce7b79cf.tar.bz2
gentoo-2-6d4c8101ca83a08a3d2af67cdda7312dce7b79cf.zip
new dep to django-compressor, initial ebuild written by me
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/ChangeLog9
-rw-r--r--dev-python/flake8/flake8-2.0.ebuild29
-rw-r--r--dev-python/flake8/metadata.xml6
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
new file mode 100644
index 000000000000..5526cbdc5bf6
--- /dev/null
+++ b/dev-python/flake8/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/flake8
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.1 2013/05/31 07:29:52 idella4 Exp $
+
+*flake8-2.0 (31 May 2013)
+
+ 31 May 2013; Ian Delaney <idella4@gentoo.org> +flake8-2.0.ebuild,
+ +metadata.xml:
+ new dep to django-compressor, initial ebuild written by me
diff --git a/dev-python/flake8/flake8-2.0.ebuild b/dev-python/flake8/flake8-2.0.ebuild
new file mode 100644
index 000000000000..e5d469002c51
--- /dev/null
+++ b/dev-python/flake8/flake8-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.0.ebuild,v 1.1 2013/05/31 07:29:52 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="http://bitbucket.org/tarek/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND=">=dev-python/pyflakes-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "tests failed"
+
+}
diff --git a/dev-python/flake8/metadata.xml b/dev-python/flake8/metadata.xml
new file mode 100644
index 000000000000..b79a85f89156
--- /dev/null
+++ b/dev-python/flake8/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
+