summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-11 19:30:09 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-11 19:30:09 +0000
commitbf2341d54c335484f67524a33c425de0449aab53 (patch)
tree14a6d5e33cd262ae508d2021f5395609a781160e /dev-python/flake8
parentversion bump (diff)
downloadgentoo-2-bf2341d54c335484f67524a33c425de0449aab53.tar.gz
gentoo-2-bf2341d54c335484f67524a33c425de0449aab53.tar.bz2
gentoo-2-bf2341d54c335484f67524a33c425de0449aab53.zip
Depend on dev-python/mccabe for tests, bug 493922 by Nikoli.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/ChangeLog5
-rw-r--r--dev-python/flake8/flake8-2.0.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/flake8/ChangeLog b/dev-python/flake8/ChangeLog
index 658e96b4c344..8f94fb9abb2a 100644
--- a/dev-python/flake8/ChangeLog
+++ b/dev-python/flake8/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/flake8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.5 2013/09/05 18:46:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/ChangeLog,v 1.6 2013/12/11 19:30:09 floppym Exp $
+
+ 11 Dec 2013; Mike Gilbert <floppym@gentoo.org> flake8-2.0.ebuild:
+ Depend on dev-python/mccabe for tests, bug 493922 by Nikoli.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> flake8-2.0.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/dev-python/flake8/flake8-2.0.ebuild b/dev-python/flake8/flake8-2.0.ebuild
index 5a556571792b..a76c8e5bc829 100644
--- a/dev-python/flake8/flake8-2.0.ebuild
+++ b/dev-python/flake8/flake8-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.0.ebuild,v 1.5 2013/09/05 18:46:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flake8/flake8-2.0.ebuild,v 1.6 2013/12/11 19:30:09 floppym Exp $
EAPI=5
@@ -13,18 +13,18 @@ HOMEPAGE="http://bitbucket.org/tarek/flake8"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="test"
LICENSE="MIT"
SLOT="0"
# requires.txt inc. mccabe however that creates a circular dep
RDEPEND=">=dev-python/pyflakes-0.6.1[${PYTHON_USEDEP}]
>=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
PDEPEND="dev-python/mccabe[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
python_test() {
esetup.py test || die "tests failed"
-
}