summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-09 06:24:34 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-09 06:24:34 +0000
commitab6d1bcef7380a247d4d19c8c68de3eb20318d4e (patch)
treef598d2bc94e609db80110098fecdb11a1c088cdc /dev-python/flask-babel
parentrevbump, migrate -> distutils-r1 (diff)
downloadgentoo-2-ab6d1bcef7380a247d4d19c8c68de3eb20318d4e.tar.gz
gentoo-2-ab6d1bcef7380a247d4d19c8c68de3eb20318d4e.tar.bz2
gentoo-2-ab6d1bcef7380a247d4d19c8c68de3eb20318d4e.zip
revbump, migrate -> distutils-r1, rm -0.8
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/ChangeLog10
-rw-r--r--dev-python/flask-babel/flask-babel-0.8-r1.ebuild44
2 files changed, 51 insertions, 3 deletions
diff --git a/dev-python/flask-babel/ChangeLog b/dev-python/flask-babel/ChangeLog
index 13c509a1f6a2..f3b8f61299f6 100644
--- a/dev-python/flask-babel/ChangeLog
+++ b/dev-python/flask-babel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-babel
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/ChangeLog,v 1.4 2012/04/19 07:55:06 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/ChangeLog,v 1.5 2013/06/09 06:24:34 idella4 Exp $
+
+*flask-babel-0.8-r1 (09 Jun 2013)
+
+ 09 Jun 2013; Ian Delaney <idella4@gentoo.org> +flask-babel-0.8-r1.ebuild:
+ revbump, migrate -> distutils-r1, rm -0.8
*flask-babel-0.8 (19 Apr 2012)
@@ -18,4 +23,3 @@
14 Dec 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+flask-babel-0.6.ebuild, +metadata.xml:
Initial version.
-
diff --git a/dev-python/flask-babel/flask-babel-0.8-r1.ebuild b/dev-python/flask-babel/flask-babel-0.8-r1.ebuild
new file mode 100644
index 000000000000..a7ef4130e85d
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-0.8-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-babel/flask-babel-0.8-r1.ebuild,v 1.1 2013/06/09 06:24:34 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Babel"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="http://packages.python.org/Flask-Babel/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}