summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-22 07:13:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-22 07:13:59 +0000
commitb5fc79e9a419c6c1f70497fe593163edcf589ecf (patch)
treecb78925dfaed26c0ceb2d6dc86f865692d59e0a6 /dev-python/flask-restless
parentCleanup. (diff)
downloadgentoo-2-b5fc79e9a419c6c1f70497fe593163edcf589ecf.tar.gz
gentoo-2-b5fc79e9a419c6c1f70497fe593163edcf589ecf.tar.bz2
gentoo-2-b5fc79e9a419c6c1f70497fe593163edcf589ecf.zip
Bump, fix docs logic
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/ChangeLog7
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/flask-restless/ChangeLog b/dev-python/flask-restless/ChangeLog
index 2ded027dcb96..7efac1fb65da 100644
--- a/dev-python/flask-restless/ChangeLog
+++ b/dev-python/flask-restless/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask-restless
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.7 2013/08/25 03:13:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.8 2013/11/22 07:13:59 patrick Exp $
+
+*flask-restless-0.12.0 (22 Nov 2013)
+
+ 22 Nov 2013; Patrick Lauer <patrick@gentoo.org> +flask-restless-0.12.0.ebuild:
+ Bump, fix docs logic
25 Aug 2013; Mike Gilbert <floppym@gentoo.org>
flask-restless-0.11.0-r1.ebuild:
diff --git a/dev-python/flask-restless/flask-restless-0.12.0.ebuild b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
new file mode 100644
index 000000000000..85c9d9f40dbd
--- /dev/null
+++ b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v 1.1 2013/11/22 07:13:59 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Flask extension for easy ReSTful API generation"
+HOMEPAGE="http://packages.python.org/Flask-Restless/"
+SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( AGPL-3 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
+ dev-python/flask-themes[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_compile_all() {
+ if use doc; then
+ if ! "${PYTHON}" -c "import flask_restless"; then
+ eerror "flask-restless is not installed. Building of the docs"
+ eerror "requires flask-restless to already be installed."
+ eerror "Firstly emerge without USE=doc, then re-emerge with USE=doc"
+ eerror ""
+ die
+ fi
+ # Changes connect to read issues @ github
+ rm -f docs/changelog.rst
+ einfo "Generating html docs for ${PN}"
+ PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
+ || die "Generating html docs for ${PN} failed"
+ fi
+}
+
+python_test() {
+ nosetests tests/test_*.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}