summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-21 23:55:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-21 23:55:12 +0000
commitdddc78100b838445d2f42939b6f53dd41a45767d (patch)
tree703f3a714e01e5fcac40ea03ef706948de47bcfc /dev-python/flask-restless
parentrm old (diff)
downloadgentoo-2-dddc78100b838445d2f42939b6f53dd41a45767d.tar.gz
gentoo-2-dddc78100b838445d2f42939b6f53dd41a45767d.tar.bz2
gentoo-2-dddc78100b838445d2f42939b6f53dd41a45767d.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask-restless')
-rw-r--r--dev-python/flask-restless/ChangeLog6
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.0.ebuild59
-rw-r--r--dev-python/flask-restless/flask-restless-0.12.1.ebuild59
-rw-r--r--dev-python/flask-restless/flask-restless-0.13.0.ebuild60
4 files changed, 5 insertions, 179 deletions
diff --git a/dev-python/flask-restless/ChangeLog b/dev-python/flask-restless/ChangeLog
index cb65763449ef..c43786600628 100644
--- a/dev-python/flask-restless/ChangeLog
+++ b/dev-python/flask-restless/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/flask-restless
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.13 2014/07/06 12:41:46 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.14 2014/12/21 23:55:12 idella4 Exp $
+
+ 21 Dec 2014; Ian Delaney <idella4@gentoo.org> -flask-restless-0.12.0.ebuild,
+ -flask-restless-0.12.1.ebuild, -flask-restless-0.13.0.ebuild:
+ rm old
06 Jul 2014; Michał Górny <mgorny@gentoo.org> flask-restless-0.12.0.ebuild,
flask-restless-0.12.1.ebuild, flask-restless-0.13.0.ebuild,
diff --git a/dev-python/flask-restless/flask-restless-0.12.0.ebuild b/dev-python/flask-restless/flask-restless-0.12.0.ebuild
deleted file mode 100644
index b2f3bbbdef8d..000000000000
--- a/dev-python/flask-restless/flask-restless-0.12.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v 1.3 2014/07/06 12:41:46 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/docbuild.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to already be installed."
- eerror "Firstly emerge without USE=doc, then re-emerge with USE=doc"
- eerror ""
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests tests/test_*.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restless/flask-restless-0.12.1.ebuild b/dev-python/flask-restless/flask-restless-0.12.1.ebuild
deleted file mode 100644
index 4975bd74f9b4..000000000000
--- a/dev-python/flask-restless/flask-restless-0.12.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.1.ebuild,v 1.2 2014/07/06 12:41:46 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restless/flask-restless-0.13.0.ebuild b/dev-python/flask-restless/flask-restless-0.13.0.ebuild
deleted file mode 100644
index ba56efc9865b..000000000000
--- a/dev-python/flask-restless/flask-restless-0.13.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.13.0.ebuild,v 1.2 2014/07/06 12:41:46 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
-
-DESCRIPTION="Flask extension for easy ReSTful API generation"
-HOMEPAGE="http://packages.python.org/Flask-Restless/"
-SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( AGPL-3 BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/mimerender[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
- dev-python/flask-themes[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-python_compile_all() {
- if use doc; then
- if ! "${PYTHON}" -c "import flask_restless"; then
- eerror "flask-restless is not installed. Building of the docs"
- eerror "requires flask-restless to be installed."
- eerror "emerge with USE=-doc followed bu USE=doc"
- die
- fi
- # Changes connect to read issues @ github
- rm -f docs/changelog.rst
- einfo "Generating html docs for ${PN}"
- PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
- || die "Generating html docs for ${PN} failed"
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}