summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-29 03:30:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-29 03:30:25 +0000
commitf9fa145bfa1b450ca70006c7f846bb85db944d52 (patch)
tree2abd8f5fe9f465a91cdd09a067a452f16a49d0cb /dev-python/flask
parent4.7.4 p1.2: Fix openssh build on alpha (bug #512586). (diff)
downloadgentoo-2-f9fa145bfa1b450ca70006c7f846bb85db944d52.tar.gz
gentoo-2-f9fa145bfa1b450ca70006c7f846bb85db944d52.tar.bz2
gentoo-2-f9fa145bfa1b450ca70006c7f846bb85db944d52.zip
update HOMEPAGE, add patches (from upstream) to fix broken tests (13 months old), update ebuild accordingly
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog8
-rw-r--r--dev-python/flask/files/flask-0.10.1-sort_json.patch54
-rw-r--r--dev-python/flask/files/flask-0.10.1-test_appcontext.patch14
-rw-r--r--dev-python/flask/flask-0.10.1-r1.ebuild13
4 files changed, 81 insertions, 8 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index a762e4aa51f4..82cb9371a87a 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.34 2014/08/21 08:23:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.35 2014/09/29 03:30:24 idella4 Exp $
+
+ 29 Sep 2014; Ian Delaney <idella4@gentoo.org>
+ +files/flask-0.10.1-sort_json.patch,
+ +files/flask-0.10.1-test_appcontext.patch, flask-0.10.1-r1.ebuild:
+ update HOMEPAGE, add patches (from upstream) to fix broken tests (13 months
+ old), update ebuild accordingly
21 Aug 2014; Agostino Sarubbo <ago@gentoo.org> flask-0.10.1-r1.ebuild:
Stable for x86, wrt bug #518474
diff --git a/dev-python/flask/files/flask-0.10.1-sort_json.patch b/dev-python/flask/files/flask-0.10.1-sort_json.patch
new file mode 100644
index 000000000000..e78cd0dee825
--- /dev/null
+++ b/dev-python/flask/files/flask-0.10.1-sort_json.patch
@@ -0,0 +1,54 @@
+https://github.com/mitsuhiko/flask/commit/a2bc61b5ab19e899735f8945f68123b4cea570d5
+diff --git a/flask/testsuite/helpers.py b/flask/testsuite/helpers.py
+index 636f67f..7de70c0 100644
+--- a/flask/testsuite/helpers.py
++++ b/flask/testsuite/helpers.py
+@@ -173,7 +173,33 @@ def index():
+ c = app.test_client()
+ rv = c.get('/')
+ lines = [x.strip() for x in rv.data.strip().decode('utf-8').splitlines()]
+- self.assert_equal(lines, [
++ sorted_by_str = [
++ '{',
++ '"values": {',
++ '"0": "foo",',
++ '"1": "foo",',
++ '"10": "foo",',
++ '"11": "foo",',
++ '"12": "foo",',
++ '"13": "foo",',
++ '"14": "foo",',
++ '"15": "foo",',
++ '"16": "foo",',
++ '"17": "foo",',
++ '"18": "foo",',
++ '"19": "foo",',
++ '"2": "foo",',
++ '"3": "foo",',
++ '"4": "foo",',
++ '"5": "foo",',
++ '"6": "foo",',
++ '"7": "foo",',
++ '"8": "foo",',
++ '"9": "foo"',
++ '}',
++ '}'
++ ]
++ sorted_by_int = [
+ '{',
+ '"values": {',
+ '"0": "foo",',
+@@ -198,8 +224,12 @@ def index():
+ '"19": "foo"',
+ '}',
+ '}'
+- ])
++ ]
+
++ try:
++ self.assert_equal(lines, sorted_by_int)
++ except AssertionError:
++ self.assert_equal(lines, sorted_by_str)
+
+ class SendfileTestCase(FlaskTestCase):
+
diff --git a/dev-python/flask/files/flask-0.10.1-test_appcontext.patch b/dev-python/flask/files/flask-0.10.1-test_appcontext.patch
new file mode 100644
index 000000000000..11dee7a9f6bf
--- /dev/null
+++ b/dev-python/flask/files/flask-0.10.1-test_appcontext.patch
@@ -0,0 +1,14 @@
+https://github.com/mitsuhiko/flask/commit/f88cc2d2f9d14d97e33ddd2bbaa4b1885db06e1c.
+diff --git a/flask/testsuite/signals.py b/flask/testsuite/signals.py
+index e061932..45ca45d 100644
+--- a/flask/testsuite/signals.py
++++ b/flask/testsuite/signals.py
+@@ -102,7 +102,7 @@ def test_appcontext_signals(self):
+ def record_push(sender, **kwargs):
+ recorded.append('push')
+ def record_pop(sender, **kwargs):
+- recorded.append('push')
++ recorded.append('pop')
+
+ @app.route('/')
+ def index():
diff --git a/dev-python/flask/flask-0.10.1-r1.ebuild b/dev-python/flask/flask-0.10.1-r1.ebuild
index c28eaaff542a..1268f6555ad2 100644
--- a/dev-python/flask/flask-0.10.1-r1.ebuild
+++ b/dev-python/flask/flask-0.10.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.9 2014/08/21 08:23:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.10 2014/09/29 03:30:24 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -11,7 +11,7 @@ DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
MY_PN="Flask"
MY_P="${MY_PN}-${PV}"
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="http://pypi.python.org/pypi/Flask"
+HOMEPAGE="https://github.com/mitsuhiko/flask/"
LICENSE="BSD"
SLOT="0"
@@ -29,16 +29,15 @@ DISTUTILS_IN_SOURCE_BUILD=1
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-is_package.patch )
+PATCHES=( "${FILESDIR}"/${P}-is_package.patch
+ "${FILESDIR}"/${P}-sort_json.patch
+ "${FILESDIR}"/${P}-test_appcontext.patch )
python_prepare_all() {
# https://github.com/mitsuhiko/flask/issues/837
sed -e s':test_uninstalled_package_paths:_&:' \
-i flask/testsuite/config.py || die
- sed -e s':test_json_key_sorting:_&:' \
- -i flask/testsuite/helpers.py || die
- sed -e s':test_appcontext_signals:_&:' \
- -i flask/testsuite/signals.py || die
+
distutils-r1_python_prepare_all
}