summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
commitd7c991004ef8a69133b601ece6a26aa932f674ef (patch)
treee2c2daf32b4fa8624d2ebbf92d5ba81e72814e0a /dev-python/foolscap
parentVersion bump. (diff)
downloadgentoo-2-d7c991004ef8a69133b601ece6a26aa932f674ef.tar.gz
gentoo-2-d7c991004ef8a69133b601ece6a26aa932f674ef.tar.bz2
gentoo-2-d7c991004ef8a69133b601ece6a26aa932f674ef.zip
Added dev-python/foolscap
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python/foolscap')
-rw-r--r--dev-python/foolscap/ChangeLog10
-rw-r--r--dev-python/foolscap/Manifest4
-rw-r--r--dev-python/foolscap/foolscap-0.3.1.ebuild30
-rw-r--r--dev-python/foolscap/metadata.xml22
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/foolscap/ChangeLog b/dev-python/foolscap/ChangeLog
new file mode 100644
index 000000000000..da8b8574b363
--- /dev/null
+++ b/dev-python/foolscap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/foolscap
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/foolscap/ChangeLog,v 1.1 2008/09/17 18:29:56 hawking Exp $
+
+*foolscap-0.3.1 (17 Sep 2008)
+
+ 17 Sep 2008; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+ +foolscap-0.3.1.ebuild:
+ Initial ebuild.
+
diff --git a/dev-python/foolscap/Manifest b/dev-python/foolscap/Manifest
new file mode 100644
index 000000000000..861621b18835
--- /dev/null
+++ b/dev-python/foolscap/Manifest
@@ -0,0 +1,4 @@
+DIST foolscap-0.3.1.tar.gz 436066 RMD160 00e90754b151fce32790f51bf2ef7a1911c48461 SHA1 0e43a84bef6a7037397d7ed2d32819a53063b540 SHA256 de08f26e59de823c8d5c3f41373cccd90043327cf00dcc0f1c3673c1b6deac87
+EBUILD foolscap-0.3.1.ebuild 674 RMD160 c0891617f2d0f0fa2302f95aec5ce7f8e35645ee SHA1 301647cfcbeecb47f790a5b86ef123375dca1cab SHA256 6512baf2e2a68b37b0ba6561218c4b5afa95d57458117f776b39f1c41e3bba1c
+MISC ChangeLog 259 RMD160 6cd5427170c140f03300169a37fad207ab09d019 SHA1 11a8032948d03ace4f5e4cec05407ad1e3bcfdb1 SHA256 66a71e708b9e2e41b541779531d6a52643d758131e857867b6723293b7cd13e4
+MISC metadata.xml 1119 RMD160 d0052abe0a21d815fd298b5666502623a3603d20 SHA1 93cd4077d540e5709d4ca2a6b165d855ea0d5425 SHA256 2aaa289cd63443ccf6929a6ea1c94df120f6800454f1b924c86f26ddce518be8
diff --git a/dev-python/foolscap/foolscap-0.3.1.ebuild b/dev-python/foolscap/foolscap-0.3.1.ebuild
new file mode 100644
index 000000000000..896af07414e4
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/foolscap/foolscap-0.3.1.ebuild,v 1.1 2008/09/17 18:29:56 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="The next-generation RPC protocol, intended to replace Perspective Broker."
+HOMEPAGE="http://foolscap.lothar.com/trac"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=dev-python/twisted-2.4.0"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ dohtml -A py,tpl,xhtml -r doc/* || die "dohtml failed"
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. trial ${PN} || die "tests failed"
+}
diff --git a/dev-python/foolscap/metadata.xml b/dev-python/foolscap/metadata.xml
new file mode 100644
index 000000000000..9c890460eaf7
--- /dev/null
+++ b/dev-python/foolscap/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+This is a ground-up rewrite of Perspective Broker, which itself is Twisted's
+native RPC/RMI protocol (Remote Procedure Call / Remote Method Invocation).
+If you have control of both ends of the wire, and are thus not constrained to
+use some other protocol like HTTP/XMLRPC/CORBA/etc, you might consider using
+Foolscap.
+
+Fundamentally, Foolscap allows you to make a python object in one process
+available to code in other processes, which means you can invoke its methods
+remotely. This includes a data serialization layer to convey the object
+graphs for the arguments and the eventual response, and an object reference
+system to keep track of which objects you are connecting to. It uses a
+capability-based security model, such that once you create a non-public
+object, it is only accessible to clients to whom you've given the
+(unguessable) FURL. You can of course publish world-visible objects that
+have well-known FURLs.
+</longdescription>
+</pkgmetadata>