summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-27 15:12:20 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-27 15:12:20 +0000
commite5ef87613aa83768bd016926d2b499837d58bc65 (patch)
tree6f2115f9a308945eaf26128329e4429e27db66b8 /dev-python/gnuplot-py
parentVersion bump, handle qt4/qt5 thanks to everyone in bug #512726 (diff)
downloadgentoo-2-e5ef87613aa83768bd016926d2b499837d58bc65.tar.gz
gentoo-2-e5ef87613aa83768bd016926d2b499837d58bc65.tar.bz2
gentoo-2-e5ef87613aa83768bd016926d2b499837d58bc65.zip
Migrate to distutils-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/gnuplot-py')
-rw-r--r--dev-python/gnuplot-py/ChangeLog9
-rw-r--r--dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/gnuplot-py/ChangeLog b/dev-python/gnuplot-py/ChangeLog
index 3ababd3fa028..e895daf21481 100644
--- a/dev-python/gnuplot-py/ChangeLog
+++ b/dev-python/gnuplot-py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gnuplot-py
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/ChangeLog,v 1.43 2012/02/23 09:15:51 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/ChangeLog,v 1.44 2014/06/27 15:12:20 jer Exp $
+
+*gnuplot-py-1.8-r1 (27 Jun 2014)
+
+ 27 Jun 2014; Jeroen Roovers <jer@gentoo.org> +gnuplot-py-1.8-r1.ebuild:
+ Migrate to distutils-r1.
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> gnuplot-py-1.8.ebuild:
Restricting python
diff --git a/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
new file mode 100644
index 000000000000..8ed63324133b
--- /dev/null
+++ b/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnuplot-py/gnuplot-py-1.8-r1.ebuild,v 1.3 2014/06/27 15:12:20 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_SINGLE_IMPL=true
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A python wrapper for Gnuplot"
+HOMEPAGE="http://gnuplot-py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot"
+
+DOCS=( ANNOUNCE.txt CREDITS.txt FAQ.txt NEWS.txt TODO.txt )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ epatch "${FILESDIR}"/${PN}-1.7-mousesupport.patch
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r doc/Gnuplot/*
+ fi
+}