summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-06-27 03:12:32 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-06-27 03:12:32 +0000
commite2ba3aafe0a620cbfd4e1288e06bfc81b0ed612f (patch)
tree5708d257b0654d603cde4c306580605af6ecc523 /dev-python/google-api-python-client
parentDitto live ebuild. (diff)
downloadgentoo-2-e2ba3aafe0a620cbfd4e1288e06bfc81b0ed612f.tar.gz
gentoo-2-e2ba3aafe0a620cbfd4e1288e06bfc81b0ed612f.tar.bz2
gentoo-2-e2ba3aafe0a620cbfd4e1288e06bfc81b0ed612f.zip
Initial commit. Dependency for app-misc/gcalcli.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/ChangeLog9
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.1.ebuild25
-rw-r--r--dev-python/google-api-python-client/metadata.xml9
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/ChangeLog b/dev-python/google-api-python-client/ChangeLog
new file mode 100644
index 000000000000..ecf0478dfb34
--- /dev/null
+++ b/dev-python/google-api-python-client/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/google-api-python-client
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/google-api-python-client/ChangeLog,v 1.1 2013/06/27 03:12:32 robbat2 Exp $
+
+*google-api-python-client-1.1 (27 Jun 2013)
+
+ 27 Jun 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +google-api-python-client-1.1.ebuild, +metadata.xml:
+ Initial commit. Dependency for app-misc/gcalcli.
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.1.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.1.ebuild
new file mode 100644
index 000000000000..756394ee2333
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/google-api-python-client/google-api-python-client-1.1.ebuild,v 1.1 2013/06/27 03:12:32 robbat2 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="http://code.google.com/p/google-api-python-client/"
+SRC_URI="https://google-api-python-client.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/python-gflags
+ >=dev-python/httplib2-0.8
+ dev-python/simplejson
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+
diff --git a/dev-python/google-api-python-client/metadata.xml b/dev-python/google-api-python-client/metadata.xml
new file mode 100644
index 000000000000..3da7d2b1eec1
--- /dev/null
+++ b/dev-python/google-api-python-client/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>robbat2@gentoo.org</email>
+<name>Robin H. Johnson</name>
+</maintainer>
+</pkgmetadata>
+