summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-23 05:14:59 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-23 05:14:59 +0000
commita6c6e41efcd0021feffaf1ebdd9b0d3962f3d70a (patch)
tree5a39b2bee7567e263f16062b8249ce8817697af9 /dev-python/hgdistver
parentFix from upstream for qecvt func decl handling #450714 by Dennis Schridde. (diff)
downloadgentoo-2-a6c6e41efcd0021feffaf1ebdd9b0d3962f3d70a.tar.gz
gentoo-2-a6c6e41efcd0021feffaf1ebdd9b0d3962f3d70a.tar.bz2
gentoo-2-a6c6e41efcd0021feffaf1ebdd9b0d3962f3d70a.zip
revbump; migrate -> distutils-r1, added link to upstream bug re the test suite
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hgdistver')
-rw-r--r--dev-python/hgdistver/ChangeLog8
-rw-r--r--dev-python/hgdistver/hgdistver-0.16-r1.ebuild26
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/hgdistver/ChangeLog b/dev-python/hgdistver/ChangeLog
index f30bb2a75a12..347fbe205023 100644
--- a/dev-python/hgdistver/ChangeLog
+++ b/dev-python/hgdistver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hgdistver
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/ChangeLog,v 1.2 2013/05/09 12:20:56 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/ChangeLog,v 1.3 2013/06/23 05:14:59 idella4 Exp $
+
+*hgdistver-0.16-r1 (23 Jun 2013)
+
+ 23 Jun 2013; Ian Delaney <idella4@gentoo.org> +hgdistver-0.16-r1.ebuild:
+ revbump; migrate -> distutils-r1, added link to upstream bug re the test suite
09 May 2013; Markus Meier <maekke@gentoo.org> hgdistver-0.16.ebuild:
add ~arm, bug #462506
@@ -10,4 +15,3 @@
10 Oct 2012; Dirkjan Ochtman <djc@gentoo.org> +hgdistver-0.16.ebuild,
+metadata.xml:
Initial version of hgdistver (for cffi, bug 437768).
-
diff --git a/dev-python/hgdistver/hgdistver-0.16-r1.ebuild b/dev-python/hgdistver/hgdistver-0.16-r1.ebuild
new file mode 100644
index 000000000000..e6895df562f5
--- /dev/null
+++ b/dev-python/hgdistver/hgdistver-0.16-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgdistver/hgdistver-0.16-r1.ebuild,v 1.1 2013/06/23 05:14:58 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="utility lib to generate python package version infos from mercurial tags"
+HOMEPAGE="http://bitbucket.org/RonnyPfannschmidt/hgdistver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ # https://bitbucket.org/RonnyPfannschmidt/hgdistver/issue/9/test-failures; train wreck
+ nosetests || die "Tests failed under ${EPYTHON}"
+}