summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-22 13:43:21 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-22 13:43:21 +0000
commitbef23192d120740f75d51f7f3d8bda15689b2919 (patch)
tree6edd563e7bcbf01765190c369cf580032d1fbced /dev-python/hglib
parentfix build with ffmpeg-1, part of bug #443196 (diff)
downloadgentoo-2-bef23192d120740f75d51f7f3d8bda15689b2919.tar.gz
gentoo-2-bef23192d120740f75d51f7f3d8bda15689b2919.tar.bz2
gentoo-2-bef23192d120740f75d51f7f3d8bda15689b2919.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/hglib')
-rw-r--r--dev-python/hglib/ChangeLog10
-rw-r--r--dev-python/hglib/hglib-0.3.ebuild30
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/hglib/ChangeLog b/dev-python/hglib/ChangeLog
index d005b708dfd4..f8c00578663d 100644
--- a/dev-python/hglib/ChangeLog
+++ b/dev-python/hglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/hglib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/ChangeLog,v 1.3 2012/03/16 07:25:07 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/ChangeLog,v 1.4 2013/01/22 13:43:21 idella4 Exp $
+
+*hglib-0.3 (22 Jan 2013)
+
+ 22 Jan 2013; Ian Delaney <idella4@gentoo.org> +hglib-0.3.ebuild:
+ bump
*hglib-0.2 (16 Mar 2012)
@@ -15,4 +20,3 @@
04 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +hglib-0.1.ebuild,
+metadata.xml:
Added dev-python/hglib-0.1, thanks to Arne Babenhauserheide. Bug #392387
-
diff --git a/dev-python/hglib/hglib-0.3.ebuild b/dev-python/hglib/hglib-0.3.ebuild
new file mode 100644
index 000000000000..61c26744a1fa
--- /dev/null
+++ b/dev-python/hglib/hglib-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hglib/hglib-0.3.ebuild,v 1.1 2013/01/22 13:43:20 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT="python2_7"
+PYTHON_USE_WITH="threads"
+
+MY_P="python-${P}"
+MY_PN="python-${PN}"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/mercurial-1.9"
+DEPEND="test? ( dev-python/nose )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ ${PYTHON} test.py
+}