summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-19 21:45:29 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-19 21:45:29 +0000
commit9b497c3a3f3bdfaacdb4cbdefb36410cb13b6a01 (patch)
tree0d3e7816845329e1dac7b875c4a39cf34f4aec6d /dev-python/html5lib
parentNix-out src_test as there are no tests. (diff)
downloadgentoo-2-9b497c3a3f3bdfaacdb4cbdefb36410cb13b6a01.tar.gz
gentoo-2-9b497c3a3f3bdfaacdb4cbdefb36410cb13b6a01.tar.bz2
gentoo-2-9b497c3a3f3bdfaacdb4cbdefb36410cb13b6a01.zip
Version bump for #404429. Thanks to Ian Delaney for attempting to get teh test suite working.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog10
-rw-r--r--dev-python/html5lib/html5lib-0.95.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
index 30f00b8ac227..9a13c6bfc125 100644
--- a/dev-python/html5lib/ChangeLog
+++ b/dev-python/html5lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/html5lib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.8 2010/10/30 22:59:19 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.9 2012/05/19 21:45:29 floppym Exp $
+
+*html5lib-0.95 (19 May 2012)
+
+ 19 May 2012; Mike Gilbert <floppym@gentoo.org> +html5lib-0.95.ebuild:
+ Version bump for #404429. Thanks to Ian Delaney for attempting to get teh test
+ suite working.
30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
html5lib-0.90.ebuild:
diff --git a/dev-python/html5lib/html5lib-0.95.ebuild b/dev-python/html5lib/html5lib-0.95.ebuild
new file mode 100644
index 000000000000..d00b9131f8b6
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.95.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.95.ebuild,v 1.1 2012/05/19 21:45:29 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="http://code.google.com/p/html5lib/ http://pypi.python.org/pypi/html5lib"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ find examples -name "*.pyc" | xargs rm -fr
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Installation of examples failed"
+ fi
+}