summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-07 14:54:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-07 14:54:50 +0000
commitf9c9c738c6606695ec88474e5a9f09e892fbaaba (patch)
treecf2077e023c5d2629b636b6bbaf09ee0b40921d5 /dev-python/ipython
parentfix typo, bug 519486, thanks Casper Ti. Vector (diff)
downloadgentoo-2-f9c9c738c6606695ec88474e5a9f09e892fbaaba.tar.gz
gentoo-2-f9c9c738c6606695ec88474e5a9f09e892fbaaba.tar.bz2
gentoo-2-f9c9c738c6606695ec88474e5a9f09e892fbaaba.zip
add doc deps, upgrade deps, shed redundant sed statements of prior versions, add patch to fix test phase, patch by cel1 now merged upstram, update install phase, add msgs in postinst relating to optional features, thanks to cel1 for cross testing a patches
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog9
-rw-r--r--dev-python/ipython/files/2.1.0-substitute-files.patch27
-rw-r--r--dev-python/ipython/ipython-2.1.0.ebuild111
3 files changed, 79 insertions, 68 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 4455cfa00576..3360e109aa70 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/ipython
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.139 2014/08/01 03:25:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.140 2014/08/07 14:54:50 idella4 Exp $
+
+ 07 Aug 2014; Ian Delaney <idella4@gentoo.org>
+ +files/2.1.0-substitute-files.patch, ipython-2.1.0.ebuild:
+ add doc deps, upgrade deps, shed redundant sed statements of prior versions,
+ add patch to fix test phase, patch by cel1 now merged upstram, update install
+ phase, add msgs in postinst relating to optional features, thanks to cel1 for
+ cross testing a patches
*ipython-2.1.0 (01 Aug 2014)
diff --git a/dev-python/ipython/files/2.1.0-substitute-files.patch b/dev-python/ipython/files/2.1.0-substitute-files.patch
new file mode 100644
index 000000000000..659df39226ac
--- /dev/null
+++ b/dev-python/ipython/files/2.1.0-substitute-files.patch
@@ -0,0 +1,27 @@
+substitute the insource files with these messages
+diff --git a/IPython/extensions/octavemagic.py b/IPython/extensions/octavemagic.py
+new file mode 100644
+index 0000000..dc93fe4
+--- /dev/null
++++ b/IPython/extensions/octavemagic.py
+@@ -0,0 +1,7 @@
++import warnings
++
++def load_ipython_extension(ip):
++ msg = ("The octavemagic extension has been moved to oct2py. "
++ "After installing oct2py, you can load octavemagic with the "
++ "following command: '%load_ext oct2py.ipython'.")
++ warnings.warn(msg, Warning, stacklevel=2)
+diff --git a/IPython/extensions/rmagic.py b/IPython/extensions/rmagic.py
+new file mode 100644
+index 0000000..739e491
+--- /dev/null
++++ b/IPython/extensions/rmagic.py
+@@ -0,0 +1,7 @@
++import warnings
++
++def load_ipython_extension(ip):
++ msg = ("The rmagic extension has been moved to rpy2. "
++ "After installing rpy2, you can load rmagic with the "
++ "following command: '%load_ext rpy2.ipython'.")
++ warnings.warn(msg, Warning, stacklevel=2)
diff --git a/dev-python/ipython/ipython-2.1.0.ebuild b/dev-python/ipython/ipython-2.1.0.ebuild
index 9b70e1ea89d0..fe8fed0f6312 100644
--- a/dev-python/ipython/ipython-2.1.0.ebuild
+++ b/dev-python/ipython/ipython-2.1.0.ebuild
@@ -1,31 +1,25 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-2.1.0.ebuild,v 1.1 2014/08/01 03:25:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-2.1.0.ebuild,v 1.2 2014/08/07 14:54:50 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE='readline,sqlite'
-inherit distutils-r1 elisp-common virtualx
+inherit distutils-r1 virtualx
DESCRIPTION="Advanced interactive shell for Python"
HOMEPAGE="http://ipython.org/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/rel-${PV}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples matplotlib mongodb notebook nbconvert octave qt4 +smp test wxwidgets"
-PY2_USEDEP=$(python_gen_usedep python2_7)
-gen_python_deps() {
- local flag
- for flag in $(python_gen_useflags '*'); do
- echo "${flag}? ( ${1}[${flag}(-)] )"
- done
-}
+IUSE="doc examples matplotlib mongodb notebook nbconvert octave qt4 +smp test wxwidgets"
+PY2_USEDEP=$(python_gen_usedep python2_7)
CDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
@@ -35,71 +29,52 @@ CDEPEND="
matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
octave? ( dev-python/oct2py[${PYTHON_USEDEP}] )
- smp? ( dev-python/pyzmq[${PYTHON_USEDEP}] )
- wxwidgets? ( dev-python/wxpython[${PY2_USEDEP}] )"
+ smp? ( >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}] )
+ wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython[${PYTHON_USEDEP}]' python2_7) )"
RDEPEND="${CDEPEND}
notebook? (
- >=www-servers/tornado-2.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-3.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
dev-libs/mathjax
- $(gen_python_deps dev-python/jinja)
)
nbconvert? (
- app-text/pandoc
+ >=app-text/pandoc-1.12.1
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
- $(gen_python_deps dev-python/jinja)
+ dev-python/jinja[${PYTHON_USEDEP}]
)
qt4? ( || ( dev-python/PyQt4[${PYTHON_USEDEP}] dev-python/pyside[${PYTHON_USEDEP}] )
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyzmq[${PYTHON_USEDEP}] )"
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-2.1.11[${PYTHON_USEDEP}] )"
DEPEND="${CDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/oct2py[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- net-libs/nodejs )"
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PY2_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/rpy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/fabric[${PYTHON_USEDEP}]' python2_7)
+ )"
-PY2_REQUSE="$(python_gen_useflags python2_7)"
-REQUIRED_USE="
- wxwidgets? ( ${PY2_REQUSE} )"
+REQUIRED_USE="doc? ( matplotlib mongodb octave )"
-DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=( ${FILESDIR}/2.1.0-substitute-files.patch
+ ${FILESDIR}/2.1.0-disable-tests.patch )
-PATCHES=( "${FILESDIR}"/2.1.0-disable-tests.patch )
+DISTUTILS_IN_SOURCE_BUILD=1
python_prepare_all() {
- # fix for gentoo python scripts
- sed -i \
- -e "/ipython_cmd/s/ipython3/ipython/g" \
- IPython/terminal/console/tests/test_console.py \
- IPython/testing/tools.py || die
-
- sed -i \
- -e "s/find_scripts(True, suffix='3')/find_scripts(True)/" \
- setup.py || die
-
- # fix gentoo installation directory for documentation
- sed -i \
- -e "/docdirbase = pjoin/s/ipython/${PF}/" \
- -e "/pjoin(docdirbase,'manual')/s/manual/html/" \
- setupbase.py || die "sed failed"
-
- if ! use doc; then
- sed -i \
- -e "/(pjoin(docdirbase, 'extensions'), igridhelpfiles),/d" \
- -e 's/ + manual_files//' \
- setupbase.py || die
- fi
-
- if ! use examples; then
- sed -i \
- -e 's/+ example_files//' \
- setupbase.py || die
- fi
+ # Remove out of date insource files
+ rm IPython/extensions/rmagic.py || die
+ rm IPython/extensions/octavemagic.py || die
+ # Prevent un-needed download during build
if use doc; then
- # Prevent un-needed download during build
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
fi
@@ -120,14 +95,12 @@ python_test() {
distutils_install_for_testing
local fail
run_tests() {
- # Run tests (-v for more verbosity).
- PYTHONPATH="${PYTHONPATH}:$(pwd)"
pushd ${TEST_DIR} > /dev/null
- "${PYTHON}" -c "import IPython; IPython.test()" || fail=1
+ "${PYTHON}" -m IPython.testing.iptestcontroller --all || fail=1
popd > /dev/null
}
-
VIRTUALX_COMMAND=run_tests virtualmake
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
}
python_install() {
@@ -137,15 +110,19 @@ python_install() {
# Create ipythonX.Y symlinks.
# TODO:
- # 1. do we want them for pypy?
+ # 1. do we want them for pypy? No. pypy has no numpy
# 2. handle it in the eclass instead (use _python_ln_rel).
- if [[ ${EPYTHON} == python* ]]; then
- dosym ../lib/python-exec/${EPYTHON}/ipython \
- /usr/bin/ipython${EPYTHON#python}
- fi
+ # With pypy not an option the dosym becomes unconditional
+ dosym ../lib/python-exec/${EPYTHON}/ipython \
+ /usr/bin/ipython${EPYTHON#python}
}
python_install_all() {
use doc && local HTML_DOCS=( docs/build/html/. )
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ elog "To enable sympyprinting, it's required to emerge sympy"
+ elog "To enable cythonmagic, it's required to emerge cython"
+}